Open Bug 1034062 Opened 6 years ago Updated 2 years ago

Reduced CSS coverage styles don't include @keyframe rules for used animations

Categories

(DevTools :: Style Editor, enhancement, P3)

enhancement

Tracking

(Not tracked)

People

(Reporter: mstange, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached file testcase
STR:
 1. Load the testcase.
 2. Open the developer toolbar (Shift+F2)
 3. Execute "csscoverage start"
 4. Refresh the page.
 5. Execute "csscoverage stop"
 6. Execute "csscoverage report"
 7. Look at the textfield in the right column of the report.


Expected results:

The textfield contents should include the @keyframes rule:
<style>
@keyframes animation {
  from {
    transform: translateY(0);
  }
  to {
    transform: translateY(10px);
  }
}
#usedRule {
	 width: 100px;
	 height: 100px;
	 border: 1px solid black;
	 animation: 0.5s ease-in-out 0s alternate none infinite animation;
 }
</style>


Actual results:

The @keyframes rule is left out:
<style>
#usedRule {
	 width: 100px;
	 height: 100px;
	 border: 1px solid black;
	 animation: 0.5s ease-in-out 0s alternate none infinite animation;
 }
</style>
Assignee: nobody → jwalker
Assignee: jwalker → nobody
Inspector bug triage (filter on CLIMBING SHOES).
Severity: normal → enhancement
Inspector bug triage (filter on CLIMBING SHOES).
Priority: -- → P3
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Assignee: ntim.bugs → nobody
Status: ASSIGNED → NEW
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.