venkman outliners are unlabelled

RESOLVED DUPLICATE of bug 103898

Status

Other Applications
Venkman JS Debugger
--
major
RESOLVED DUPLICATE of bug 103898
16 years ago
13 years ago

People

(Reporter: Jesse Ruderman, Assigned: Robert Ginda)

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
It took me several minutes to become oriented in the new JavaScript debugger.  
One of the main problems is that there are five panes, all open by default, and 
three of them don't have any indication of what they are.

When I load venkman, I see:
- An outliner with one item, "Breakpoints".  The item has an expander, but 
expanding it does nothing.  The columns of the outliner are unlabelled.
- An empty outliner with columns "name" and "line".
- An empty outliner with columns "name" and "value".

How I think it should look:
- The first outliner should contain the text "No breakpoints set".  The text 
should be centered horizontally within the outliner, near the top (as in 
outlook express for an empty mail folder).
- The second outliner should contain the text "No scripts or pages loaded".
- The third outliner should contain the text "No call stack available" or "No 
scripts are paused".
(Assignee)

Comment 1

16 years ago
yeah, of course.  give me some time, will ya?
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → LATER
Don't use LATER.  Reopening, futuring.
Status: RESOLVED → REOPENED
Resolution: LATER → ---
Target Milestone: --- → Future
(Assignee)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 103898 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.