Closed Bug 1034296 Opened 8 years ago Closed 7 years ago

Action dropdown in Application pane does not open when session restored

Categories

(Firefox :: Preferences, defect, P2)

33 Branch
defect
Points:
3

Tracking

()

RESOLVED FIXED
Iteration:
38.3 - 23 Feb
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- verified
firefox38 --- verified
firefox-esr31 --- unaffected

People

(Reporter: alice0775, Assigned: Gijs)

References

Details

(Keywords: regression, Whiteboard: [see comment 10])

Steps To Reproduce:
1. Open Preferences ( about:preferences )
2. Select Applications
3. Select an application and try to select an action
   --- dropdown appears as expected.

4. Exit browser and restart
5. Restore Previous Session
6. Try to select the action of the application which was selected at step3
   --- dropdown fails. this is bug.

Actual Results:
   Dropdown fails.
   No up/down arrow.

Expected Results:
   Dropdown should appear.
please ignore comment #1
Steps To Reproduce:
0. browser.preferences.inContent = true
1. Open Preferences ( about:preferences )
2. Select Applications
3. Select an application and try to select an action
   --- dropdown appears as expected.

4. Exit browser and restart
5. Restore Previous Session
6. Try to select the action of the application which was selected at step3
   --- dropdown fails. this is bug.

Actual Results:
   Dropdown fails.
   No up/down arrow.

Expected Results:
   Dropdown should appear.


Regression window(fx):
Good:
http://hg.mozilla.org/integration/fx-team/rev/0a2824f4e03b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140124085803
Bad:
http://hg.mozilla.org/integration/fx-team/rev/c7c63c6c2433
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140124091931
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=0a2824f4e03b&tochange=c7c63c6c2433

Regressed by: Bug 960903
Summary: Action dropdown in Apprication pane does not open when open it next time / session restore → Action dropdown in Apprication pane does not open when session restored
Tim,

Could you have a look at this?
Flags: needinfo?(ttaubert)
Alice, is there a workaround for when the user gets in this state? Can they toggle tabs or select a different row to get it to work again?
Flags: needinfo?(alice0775)
(In reply to Matthew N. [:MattN] (behind on bugmail) from comment #5)
> Alice, is there a workaround for when the user gets in this state? 

Close tab, and re-open about:preferences.

>Can they toggle tabs or select a different row to get it to work again?

No.
Flags: needinfo?(alice0775)
We are going to release in-tab preferences. Tracking to make sure it is polish.
Summary: Action dropdown in Apprication pane does not open when session restored → Action dropdown in Application pane does not open when session restored
(In reply to Alice0775 White from comment #6)
> (In reply to Matthew N. [:MattN] (behind on bugmail) from comment #5)
> > Alice, is there a workaround for when the user gets in this state? 
> 
> Close tab, and re-open about:preferences.

Switch to another pane (e.g. "Content") and then back to "Applications" fixes it for me.
Flags: needinfo?(ttaubert)
(In reply to Tim Taubert [:ttaubert] from comment #8)
> Switch to another pane (e.g. "Content") and then back to "Applications"
> fixes it for me.

I was wrong, guess I didn't understand the STR. The row that was selected when quitting Firefox is the only one that breaks upon restart.
If you remove the "lastSelectedType" attribute from "_list" in gApplicationsPane.init() then everything works fine. This can't be the right solution however as we implicitly persist the aforementioned attribute and even try to handle that somehow in _selectLastSelectedType().

This doesn't seem very specific to sessionstore, I can't get to this right now but it should be easy for someone else to pick up from here.
Keywords: qawanted
OS: Windows 7 → All
Hardware: x86_64 → All
Flags: firefox-backlog+
Points: --- → 3
in-tab preferences are not going to be part of 33. No need to take a patch now.
AFAIK, we're not shipping in content prefs in 34 either. I'm dropping tracking for 34 and more generally for this bug.
Priority: -- → P2
Whiteboard: [see comment 10]
Taking this for the next iteration...
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 38.3 - 23 Feb
Flags: qe-verify?
I can't reproduce this (using steps from comment #0, comment #3). Alice, are you still seeing this?

I'm guessing this got fixed by our changes to the initialization of about:preferences, but I'm not sure.
Flags: needinfo?(alice0775)
(In reply to :Gijs Kruitbosch from comment #14)
> I can't reproduce this (using steps from comment #0, comment #3). Alice, are
> you still seeing this?
> 
> I'm guessing this got fixed by our changes to the initialization of
> about:preferences, but I'm not sure.

indeed, i can not reproduce on latest Nightly38.0a2.

However, I can still reproduce on latest Dev37.0a2.
https://hg.mozilla.org/releases/mozilla-aurora/rev/13bf0a02fa62
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150210004330
Flags: needinfo?(alice0775) → needinfo?(gijskruitbosch+bugs)
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=34e2d2bd7ec4&tochange=a6bbabebed2f

This was fixed by bug 1012223, it looks like. I'll ask for uplift there...
Flags: needinfo?(gijskruitbosch+bugs)
Depends on: 1012223
Closing this out because it's fixed on trunk.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: qe-verify?
Flags: qe-verify-
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.