Plugins can't consume mouse clicks [Affects OJI Java Plugin]

VERIFIED FIXED

Status

()

Core
Event Handling
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Patrick C. Beard, Assigned: Patrick C. Beard)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] [on trunk] [OSX+], URL)

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
In nsObjectFrame.cpp, line 3198, when a mouseDown event gets sent to a plugin,
the event can never be consumed if it is of type NS_MOUSE_LEFT_BUTTON_DOWN. This
makes interacting with a Java applet using the mouse very awkward, as the
browser often interprets the click as beginning a drag. I have a simple patch
that fixes this problem, authored by myself and Chris Saari.
(Assignee)

Comment 1

17 years ago
Created attachment 52332 [details] [diff] [review]
Fix to allow plugins to consume mouse click events.
(Assignee)

Updated

17 years ago
Keywords: nsbranch, patch
Whiteboard: [review needed]

Comment 2

17 years ago
Comment on attachment 52332 [details] [diff] [review]
Fix to allow plugins to consume mouse click events.

r=peterl  nice!   strange the code says we consume context menu events yet we still get a XUL menu after a native one on Mac
Attachment #52332 - Flags: review+
(Assignee)

Comment 3

17 years ago
We should file a separate bug on the problem with CONTEXTMENU events. This is
caused by a problem in widget code.
(Assignee)

Comment 4

17 years ago
Needs a super review, simon?

Comment 5

17 years ago
Comment on attachment 52332 [details] [diff] [review]
Fix to allow plugins to consume mouse click events.

sr=sfraser
Attachment #52332 - Flags: superreview+
(Assignee)

Comment 6

17 years ago
Fix checked into trunk.
Assignee: joki → beard
(Assignee)

Updated

17 years ago
Whiteboard: [review needed] → PDT [on trunk]

Comment 7

17 years ago
can we test a few plugins on this one, specifically sites with flash.
Whiteboard: PDT [on trunk] → [PDT] [on trunk] [OSX+]

Comment 8

17 years ago
pls check this into the 094 branch - PDT+, pending shrir test verification.
Whiteboard: [PDT] [on trunk] [OSX+] → [PDT+] [on trunk] [OSX+]

Comment 9

17 years ago
shrir or pmac - can you do some quick tests on plugins and mouseclicks within
the plugins on the trunk?

Is this fix isolated to Mac only?
(Assignee)

Comment 10

17 years ago
This fix is Mac only, as indicated above by the platform.

Comment 11

17 years ago
tested flash and quicktime and things look ok. mouse clicks work and I do not 
see any wrong results, sites/plugins function properly. Tested on 1009 trunk on 
OS x.1
(Assignee)

Comment 12

17 years ago
Fix checked in on 0.9.4 branch.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
changing QA contact. 

Srirang, Please verfiy this bug on branch build. Thanks!!
QA Contact: madhur → shrir

Comment 14

17 years ago
Since Shrirang is on vacation, so I'm verifying this bug for him.
Tested quicktime and looked ok. Mouse clicks worked fine. Verified on
Mac OSX 10.1 (branch build: 2001-10-22-18-0.9.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.