FUTEX_WAIT_PRIVATE Resource temporarily unavailable crash

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
--
critical
RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: lso, Unassigned)

Tracking

({crash})

30 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.93 Safari/537.36

Steps to reproduce:

Current 30 release of Firefox with Pipelight and UserAgentOverrider.  Go to the netflix.com website and it crashes on playback.  Also, random crashes on other websites (but I have not run strace on all other sites).


Actual results:

Consistent crashing with the error messages:
futex(0x7fe85e82a8dc, FUTEX_CMP_REQUEUE_PRIVATE, 1, 2147483647, 0x7fe85e82a878, 1008) = 1
futex(0x7fe879b35048, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x7fe879b35048, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x7fe879b35048, FUTEX_WAKE_PRIVATE, 1) = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_ACCERR, si_addr=0x7fe840536ecb} ---
+++ killed by SIGSEGV (core dumped) +++
[9145] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/firefox-30.0/mozilla-release/ipc/glue/MessageChannel.cpp, line 1522
[9145] ###!!! ABORT: Aborting on channel error.: file /builddir/build/BUILD/firefox-30.0/mozilla-release/ipc/glue/MessageChannel.cpp, line 1522


Expected results:

Firefox r30 crashes.
(Reporter)

Comment 1

4 years ago
Fogot about this message on the console:

fixme:advapi:UnregisterTraceGuids 0: stub
fixme:advapi:UnregisterTraceGuids 0: stub

Comment 2

4 years ago
Does Crash Reporter start?
Flags: needinfo?(lso)
Keywords: crash
(Reporter)

Comment 3

4 years ago
The crash reporter never starts, even though it is enabled.  Looking at the about:crashes status page
always indicates:

   Submitted Crash Reports

   No crash reports have been submitted.
Flags: needinfo?(lso)

Updated

4 years ago
Severity: normal → critical
Are you able to reproduce this without when your add-ons are disabled?

Comment 5

3 years ago
Hi Reporter, 

Considering new Firefox versions were released since last activity on this bug, could you re-test on a new Firefox version? Ex: Firefox 43 - https://www.mozilla.org/en-US/firefox/new/, or Nightly 46 - https://nightly.mozilla.org/. 

If still reproducible, please try in Firefox Safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and also with a new profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles).
Flags: needinfo?(lso)

Comment 6

2 years ago
 Closing this as incomplete due to inactivity and lack of response from the reporter. Feel free to reopen the bug if the issue still reproduces on a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lso)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.