If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Correctly use noun/verb forms of Login/Log In and Logout/Log Out where appropriate

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Shane H. W. Travis)

Tracking

2.10
Bugzilla 2.20
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
Build: bugzilla.mozilla.org

To reproduce:
1.  Delete your Bugzilla cookies.
2.  Make a change to a bug.

What you see:
*   `Login'
*   `Login'
*   `Login'

What you should see:
*   `Log in to Bugzilla'
*   `Log in'
*   `Log In'

Login is a noun. This page is asking you to log in, which is a verb.
(Reporter)

Updated

16 years ago
Severity: normal → trivial
simple trivial fix I think...  should be able to get this in.
Target Milestone: --- → Bugzilla 2.16
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 3

16 years ago
Another related user interface issue that I wasn't sure was worth creating
another bug report - the terminology used on the "Login" page is inconsistent. 
It reads "If you have forgotten your password, enter your login name....".  To
make this consistent with the term used elsewhere I think it should say "login
name(e-mail address)" or just "e-mail address" instead of "login name". 
Everywhere else it is refered to as your "E-Mail address".
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk

Comment 6

14 years ago
Unloved bugs targetted for 2.18 but untouched since 9-15-2003 are being
retargeted to 2.20
If you plan to act on one immediately, go ahead and pull it back to 2.18.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20

Comment 7

13 years ago
Actually, "login name" is valid. But the verb form would be "log in."

By the way, I think it is now fixed everywhere, already. Or does the UI still
say "login" in some places where it shouldn't?
(Assignee)

Comment 8

13 years ago
dunno about login'... but it says 'Logout' here when it shouldn't:

./templates/en/default/index.html.tmpl:    <li id="logout"><a 
href="relogin.cgi">Logout [% user.login FILTER html %]</a></li>

     Should be 'Log out'.


Comment 9

13 years ago
This bug has not been touched by its owner in over six months, even though it is
targeted to 2.20, for which the freeze is 10 days away. Unsetting the target
milestone, on the assumption that nobody is actually working on it or has any
plans to soon.

If you are the owner, and you plan to work on the bug, please give it a real
target milestone. If you are the owner, and you do *not* plan to work on it,
please reassign it to nobody@bugzilla.org or a .bugs component owner. If you are
*anybody*, and you get this comment, and *you* plan to work on the bug, please
reassign it to yourself if you have the ability.
Target Milestone: Bugzilla 2.20 → ---
(Assignee)

Updated

13 years ago
Assignee: myk → travis
Summary: `Login' should be `Log In' → Correctly use noun/verb forms of Login/Log In and Logout/Log Out where appropriate
(Assignee)

Comment 10

13 years ago
Created attachment 176583 [details] [diff] [review]
Code patch for tip

This patch appropriately changes the UI to use Log In/Log Out where it is
talking about an action the user must take, and 'login' where it it talking
about a user's identifying characteristics.

I have also removed the word 'name' from the phrase 'login name' wherever I
found it (comments as well) as it is deceptive and inaccurate. The login need
not be a name, and in fact is NOT a name; to call it such is sloppy, and risks
misunderstanding.

Should be doable for 2.20, retargeting it as such.
Attachment #176583 - Flags: review?(timeless)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Bugzilla 2.20
(Assignee)

Comment 11

13 years ago
Created attachment 176584 [details] [diff] [review]
Code patch for tip, take 2

removed the docs patch that accidentally got included.
Attachment #176583 - Attachment is obsolete: true
Attachment #176584 - Flags: review?(timeless)
(Assignee)

Updated

13 years ago
Attachment #176583 - Flags: review?(timeless)
Comment on attachment 176584 [details] [diff] [review]
Code patch for tip, take 2

>Index: attachment.cgi

>-    # Get the user's login name since the AppendComment function needs it.
>+    # Get the user's login since the AppendComment function needs it.

login name -> username here and elsewhere (username is the most common name for
this and has an unambiguous meaning).


>Index: template/en/default/account/auth/login.html.tmpl

>-  title = "Login",
>+  title = "Log in to Bugzilla",

Log in -> Log In
Bugzilla -> $terms.Bugzilla


>-  <input type="submit" name="GoAheadAndLogIn" value="Login">
>+  <input type="submit" name="GoAheadAndLogIn" value="Log in">

Log in -> Log In


>-    Otherwise, you will frequently be required to re-login.)
>+    Otherwise, you will be required to log in frequently.)

log in -> re-log in

Otherwise this looks good and is a welcome fix.
Attachment #176584 - Flags: review?(timeless) → review-
(Reporter)

Comment 13

13 years ago
If I may be permitted to disagree, Myk, the patch looks good to me. Here's why:

> >+  title = "Log in to Bugzilla",
> 
> Log in -> Log In

Usual hyperlink capitalization is sentence case, as used in the patch, not title
case. (Even if it was title case, why capitalize "In" but not "to"?)

> >+  <input type="submit" name="GoAheadAndLogIn" value="Log in">
> 
> Log in -> Log In

Same here -- it's a link, correctly using sentence case.

> >-    Otherwise, you will frequently be required to re-login.)
> >+    Otherwise, you will be required to log in frequently.)
> 
> log in -> re-log in

"Re-" is redundant with "frequently" -- if I have to do it frequently, of course
I'm having to re-do it. Again, I think the patch here is correct.
(Assignee)

Comment 14

13 years ago
(In reply to comment #12)
> login name -> username here and elsewhere (username is the most common name
> for this and has an unambiguous meaning).

Username is not any more common than 'login' or 'login name'; in fact, it is 
found almost exclusively in user-error, while the other two are found in many 
other templates.

'login name' is *definitely* wrong, because the login is not a name at all; it 
is an email address. As such, I fixed these simply by dropping the extra word. 
By this same logic, I am against changing 'login' to 'username' ... since they 
aren't names.


> >Index: template/en/default/account/auth/login.html.tmpl
> >-  title = "Login",
> >+  title = "Log in to Bugzilla",
> Log in -> Log In
> Bugzilla -> $terms.Bugzilla

Agree with the last (don't templates get checked? Shouldn't this have triggered 
an error in the testing suite?) but disagree with the former for the reasons 
stated by the previous poster; if we're not capiitalizing 'to', then we 
shouldn't be capitalizing 'in'.

> >-    Otherwise, you will frequently be required to re-login.)
> >+    Otherwise, you will be required to log in frequently.)
> log in -> re-log in

Again, the change in word order was done deliberately to remove the 're-' 
prefix, and I'd rather not put it back if at all possible. Grammatically, this 
is correct, and the meaning is clear.


> Otherwise this looks good and is a welcome fix.

Thank you. If the 'username' vs. 'login' thing is really contentious, I'll 
remove it entirely and open another bug to make usage consistent throughout... 
but I'll still argue in favour of the latter over the former.
what we're currently calling "login_name" is an email address only if the system
is not using the emailsuffix param.  Otherwise it's a local username.  Since it
could probably be either, something more general like 'login' is probably more
accurate.  On the other hand, to prevent confusion, maybe that should be a term
set based on whether emailsuffix is in use or not in the UI.  Then it could be
accurate and still specific enough to not confuse people.
> Usual hyperlink capitalization is sentence case, as used in the patch,
> not title case.

My approach is to use sentence case for prose links and title case for
freestanding links, as the latter are more akin to UI elements like buttons and
menu items, and such elements traditionally use title case.


> if we're not capiitalizing 'to', then we shouldn't be capitalizing 'in'.

"to" is a preposition, while "in" is part of the prepositional verb "log in". 
Per traditional title capitalization guidelines, prepositions in prepositional
verbs (a.k.a. verb phrases) should be capitalized.  See for example the
Microsoft Manual of Style for Technical Publications, an excerpt from which can
be found on the following page:

http://www.tc-forum.org/topicmai/ml03capi.htm

But "Log in" is still better than "login", so I reduce that review comment to
the status of a nit.


> Again, the change in word order was done deliberately to remove the 're-' 
> prefix, and I'd rather not put it back if at all possible.

Seems reasonable.  Comment rescinded.

Please do open a new bug for login name -> login vs. username so that debate on
it doesn't delay these other changes.
(Assignee)

Comment 17

13 years ago
Created attachment 177913 [details] [diff] [review]
Code patch for tip, take 3

Changes as per your last comment.
Attachment #176584 - Attachment is obsolete: true
Attachment #177913 - Flags: review?(myk)
(Assignee)

Comment 18

13 years ago
New bug 286786 filed to deal with 'login name'.
Attachment #177913 - Flags: review?(myk) → review+
Flags: approval+
(Assignee)

Comment 19

13 years ago
Checking in template/en/default/index.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/index.html.tmpl,v  <--  
index.html.tmpl
new revision: 1.22; previous revision: 1.21
done
Checking in template/en/default/sidebar.xul.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/sidebar.xul.tmpl,v  <--  
sidebar.xul.tmpl
new revision: 1.17; previous revision: 1.16
done
Checking in template/en/default/account/auth/login.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/account/auth/login.html.t
mpl,v  <--  login.html.tmpl
new revision: 1.11; previous revision: 1.10
done
Checking in template/en/default/pages/bug-writing.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/bug-
writing.html.tmpl,v  <--  bug-writing.html.tmpl
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.