marionette.py found inside gecko has not upgraded to 7.10

RESOLVED WONTFIX

Status

P1
blocker
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: tkundu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8450780 [details]
diff

[1] says that gaia_ui_tests needs marionette client 7.10 
and if we download [2] and compare with [3] 

then we see a big difference (see attachment).

This is observed in FFOS 2.0 tip.

and if any python script uses [3] and calls |import marionette| then it gives following error (Exact command used: runtests.py <JS testscript>):

(Forwarding device port: 3865)
(Activating Marionette virtual environment. |deactivate| to exit)
Run tests
Traceback (most recent call last):
  File "/local/mnt/buildbot/boottest_8610/build/out/host/marionette//client/marionette/runtests.py", line 7, in <module>
    from marionette_test import MarionetteTestCase, MarionetteJSTestCase
  File "/local/mnt/buildbot/boottest_8610/build/out/host/marionette/client/marionette/marionette_test.py", line 25, in <module>
    from marionette import Marionette
  File "/local/mnt/buildbot/boottest_8610/build/out/host/marionette/client/marionette/marionette.py", line 29, in <module>
    import geckoinstance
  File "/local/mnt/buildbot/boottest_8610/build/out/host/marionette/client/marionette/geckoinstance.py", line 87, in <module>
    class CloneRunner(Runner):
TypeError: Error when calling the metaclass bases
    function() argument 1 must be code, not str





but if we force |import marionette| to use marionette.py from [2] then this error does not come.


[1] https://github.com/mozilla-b2g/gaia/blob/v2.0/tests/python/gaia-ui-tests/requirements.txt
[2] https://pypi.python.org/pypi/marionette_client/0.7.10
[3] gecko/testing/marionette/client/marionette/marionette.py
blocking-b2g: --- → 2.0?

Updated

4 years ago
Component: General → Gaia::UI Tests

Comment 1

4 years ago
Marionette
Component: Gaia::UI Tests → Marionette
Product: Firefox OS → Testing
According to mdas, we need to uplift 0.7.10 to mozilla-aurora (i.e., B2G 2.0).  I'll do that today.
Note that we don't support running gaia-ui-tests against in-tree Marionette, except on master.  For all other versions, you should use requirements.txt to install the appropriate packages from PyPI.

The diff you included looks like you're trying to run a 2.0 version of gaiatest with the copy of Marionette currently in mozilla-central, which is definitely not supported.
(In reply to Jonathan Griffin (:jgriffin) from comment #2)
> According to mdas, we need to uplift 0.7.10 to mozilla-aurora (i.e., B2G
> 2.0).  I'll do that today.

I looked at this, and there are quite a number of changes that would have to be uplifted.  Since we don't support running gaia-test with in-tree Marionette in general, I'd like to WONTFIX this, since uplifting all those patches is potentially risky for other in-tree automation.

The correct fix to this problem is to use requirements.txt for running gaia-test, e.g., just doing

   python setup.py install

from the gaia-ui-tests directory.

Re-open please if you think this is really important for some reason.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(In reply to Jonathan Griffin (:jgriffin) from comment #3)
> Note that we don't support running gaia-ui-tests against in-tree Marionette,
> except on master. 

Oh!

For master, would it be fine to assume that we can use the gaia-ui-tests's version of Marionette as well
blocking-b2g: 2.0? → ---
(In reply to Michael Vines [:m1] [:evilmachines] from comment #5)
> (In reply to Jonathan Griffin (:jgriffin) from comment #3)
> > Note that we don't support running gaia-ui-tests against in-tree Marionette,
> > except on master. 
> 
> Oh!
> 
> For master, would it be fine to assume that we can use the gaia-ui-tests's
> version of Marionette as well

Yes, that's always the safest way to run gaia-ui-test.
You need to log in before you can comment on or make changes to this bug.