Merge all test manifests into one (and provide way to enable/disable)

RESOLVED DUPLICATE of bug 1039140

Status

Testing
JSMarionette
RESOLVED DUPLICATE of bug 1039140
4 years ago
4 years ago

People

(Reporter: zac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
The current manifest configuration is one for TBPL, one for Travis.

However this configuration will not scale well. To follow this style will be one manifest for Tarako, one for Flame, one for TBPL on mac, one for TBPL on linux, etc etc. and soon there might be 4 or 5 manifest files.

Often in separate manifest files a test will get disabled in one but not in the other as people either don't know or forget about the other manifests.

Sometimes tests need to be disabled for all platforms and sometimes for only one platform which involves sifting through files.

IMO it would be best to merge all the manifests into one so that each test is listed once and provide attributes to enable/disable based on hardware or other capabilities of the platform.
This is also going to be fixed by bug 994847. I'm adding manifestparser manifests to all gaia-integration tests as part of that bug.
I guess I can use this bug for that work though to make the patch in the other bug simpler.
Blocks: 994847
(Reporter)

Comment 3

4 years ago
manifestparser will solve this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1039140
You need to log in before you can comment on or make changes to this bug.