Closed Bug 1034607 Opened 6 years ago Closed 6 years ago

Regression: Sync promo mangled with active tab list in the tab tray

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox32 --- unaffected
firefox33 --- verified
fennec + ---

People

(Reporter: aaronmt, Assigned: Epransky)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Attached image screenshot.png
See screenshot.

Currently the Sync promo can become mangled with the active tab listing in the tabs tray.

The following are some steps to reproduce I stumbled upon while testing bug 1034558.

  Launch Nightly
  Visit http://whatsapp.com
  Tap the 'Download' button to open Google Play
  Hit the back button to return to the browser
  Open the tab tray

Nightly (07/04)
LG Nexus 5 (Android 4.4.4)
Thinking this might be breakage from either bug 1016613 or bug 1024778.

Related also, the Sync promo text disappears from the pane on device orientation change.
Easier to reproduce just by hitting home, bringing the browser back up and opening the tabs pane actually.
Same range as bug 1034609

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2b018836f449&tochange=dc28da9f9d80

e01dbdf8a218	Ethan Pransky — Bug 1016613 - Replaced RemoteTabsPanel view with ViewStub in tabs_panel.xml and created new layout file to inflate the ViewStub when user clicks on 3rd button in TabsPanel. r=mcomella
I have a fix for this, but it's dependent on a patch I submitted for Bug 1034384, which hasn't been reviewed/accepted (because I only recently submitted it). Not sure how I should submit a patch here with that being the case. Should I just include the fix in a new patch for 1034384 and mention in a comment that it also resolves this bug?
^
Flags: needinfo?(michael.l.comella)
(In reply to Epransky from comment #4)
> I have a fix for this, but it's dependent on a patch I submitted for Bug
> 1034384, which hasn't been reviewed/accepted (because I only recently
> submitted it). Not sure how I should submit a patch here with that being the
> case. Should I just include the fix in a new patch for 1034384 and mention
> in a comment that it also resolves this bug?

Typically, a comment referencing the fact that a patch is underway in bug X (in this case, bug 1034384) is added to the bug (like what you did in comment 4) and once the patch lands, the bug is marked as a duplicate to bug X.

You could mark the bug as a duplicate earlier if you're sure the issue will be fixed, but I like to wait until the patch lands.
Flags: needinfo?(michael.l.comella)
It's also probably a good idea to assign yourself to the bug, so no one wastes time attempting to start a solution.
Assignee: nobody → Epransky
Status: NEW → ASSIGNED
(In reply to Michael Comella (:mcomella) from comment #6)
> (In reply to Epransky from comment #4)
> > I have a fix for this, but it's dependent on a patch I submitted for Bug
> > 1034384, which hasn't been reviewed/accepted (because I only recently
> > submitted it). Not sure how I should submit a patch here with that being the
> > case. Should I just include the fix in a new patch for 1034384 and mention
> > in a comment that it also resolves this bug?
> 
> Typically, a comment referencing the fact that a patch is underway in bug X
> (in this case, bug 1034384) is added to the bug (like what you did in
> comment 4) and once the patch lands, the bug is marked as a duplicate to bug
> X.
> 
> You could mark the bug as a duplicate earlier if you're sure the issue will
> be fixed, but I like to wait until the patch lands.

Cool. I added the fix for this bug to the patch in Bug 1034384. I'll wait until that patch lands and make sure that it really does resolve this bug as well.

Thanks for assigning me to this. I should've done that before...
Duplicate of this bug: 1036811
Bug 1016613 has been backed out, will hopefully make today's nightly.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Duplicate of this bug: 1036836
tracking-fennec: ? → +
Duplicate of this bug: 1037935
Verified as fixed in build:
Firefox for Android 33.0a1 (2014-07-15)
Devices:
Galaxy Nexus (Android 4.2.1)
Samsung S3 (Android 4.3)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.