crash in OOM | unknown | js::CrashAtUnhandlableOOM(char const*) | JSC::Yarr::YarrGenerator<int>::opCompileAlternative(JSC::Yarr::PatternAlternative*)

RESOLVED DUPLICATE of bug 999165

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 999165
4 years ago
4 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash, topcrash-win})

31 Branch
x86
Windows NT
crash, topcrash-win
Points:
---

Firefox Tracking Flags

(firefox30 unaffected, firefox31+ wontfix, firefox32 unaffected, firefox33 unaffected)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-355fb236-e9ea-4560-8a17-762482140627.
=============================================================
0 	mozjs.dll 	js::CrashAtUnhandlableOOM(char const *) 	js/src/jscntxt.cpp
1 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::opCompileAlternative(JSC::Yarr::PatternAlternative *) 	js/src/yarr/YarrJIT.cpp
2 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::opCompileParenthesesSubpattern(JSC::Yarr::PatternTerm *) 	js/src/yarr/YarrJIT.cpp
3 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::opCompileAlternative(JSC::Yarr::PatternAlternative *) 	js/src/yarr/YarrJIT.cpp
4 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::opCompileParenthesesSubpattern(JSC::Yarr::PatternTerm *) 	js/src/yarr/YarrJIT.cpp
5 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::opCompileAlternative(JSC::Yarr::PatternAlternative *) 	js/src/yarr/YarrJIT.cpp
6 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::opCompileBody(JSC::Yarr::PatternDisjunction *) 	js/src/yarr/YarrJIT.cpp
7 	mozjs.dll 	JSC::Yarr::YarrGenerator<0>::compile(JSC::Yarr::JSGlobalData *,JSC::Yarr::YarrCodeBlock &) 	js/src/yarr/YarrJIT.cpp
8 	mozjs.dll 	JSC::Yarr::jitCompile(JSC::Yarr::YarrPattern &,JSC::Yarr::YarrCharSize,JSC::Yarr::JSGlobalData *,JSC::Yarr::YarrCodeBlock &,JSC::Yarr::YarrJITCompileMode) 	js/src/yarr/YarrJIT.cpp
9 	mozjs.dll 	js::RegExpShared::compile(JSContext *,JSLinearString &,bool) 	js/src/vm/RegExpObject.cpp
10 	mozjs.dll 	js::RegExpShared::compile(JSContext *,bool) 	js/src/vm/RegExpObject.cpp
11 	mozjs.dll 	js::RegExpShared::compileMatchOnlyIfNecessary(JSContext *) 	js/src/vm/RegExpObject.cpp
12 	mozjs.dll 	js::RegExpShared::executeMatchOnly(JSContext *,wchar_t const *,unsigned int,unsigned int *,js::MatchPair &) 	js/src/vm/RegExpObject.cpp
13 	mozjs.dll 	DoMatchGlobal 	js/src/jsstr.cpp
14 	mozjs.dll 	js::str_match(JSContext *,unsigned int,JS::Value *) 	js/src/jsstr.cpp
15 		@0x21ac0b4 	
16 		@0x6572ba78 	
17 		@0x157f08f4 	
18 	mozjs.dll 	EnterBaseline 	js/src/jit/BaselineJIT.cpp
19 	mozjs.dll 	js::jit::EnterBaselineMethod(JSContext *,js::RunState &) 	js/src/jit/BaselineJIT.cpp
20 	mozjs.dll 	js::RunScript(JSContext *,js::RunState &) 	js/src/vm/Interpreter.cpp
21 	mozjs.dll 	js::Invoke(JSContext *,JS::CallArgs,js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
22 	mozjs.dll 	js::Invoke(JSContext *,JS::Value const &,JS::Value const &,unsigned int,JS::Value const *,JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
23 	mozjs.dll 	js::jit::DoCallFallback 	js/src/jit/BaselineIC.cpp
24 		@0x157f547d 	
25 		@0x656e6780 	
26 		@0x157f08f4 	
27 	mozjs.dll 	EnterBaseline 	js/src/jit/BaselineJIT.cpp
28 	mozjs.dll 	js::jit::EnterBaselineAtBranch(JSContext *,js::InterpreterFrame *,unsigned char *) 	js/src/jit/BaselineJIT.cpp
29 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
30 		@0x28ac1780 	
=============================================================
More reports: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=OOM+%7C+unknown+%7C+js%3A%3ACrashAtUnhandlableOOM%28char+const%2A%29+%7C+JSC%3A%3AYarr%3A%3AYarrGenerator%3Cint%3E%3A%3AopCompileAlternative%28JSC%3A%3AYarr%3A%3APatternAlternative%2A%29

This is our #6 topcrash in Beta, accounting for 2.34% of our crashes currently. Given this is YARR, I'm not sure we will be able to do anything for Firefox 31 but I'm filing it anyway.

I'm not seeing any reports of this crash for anything other than Firefox 31 at this point so there may be a regression.
(Reporter)

Updated

4 years ago
Keywords: topcrash-win
Top crash, tracking!
tracking-firefox31: ? → +

Comment 2

4 years ago
We already decided a few weeks ago that those Yarr crashes are WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox31: affected → wontfix
Resolution: --- → WONTFIX

Comment 3

4 years ago
And actually this is a dupe of bug 999165.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 999165
You need to log in before you can comment on or make changes to this bug.