Repaint problem on Titlebar after clicking on Menubar

RESOLVED DUPLICATE of bug 37540

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 37540
17 years ago
10 years ago

People

(Reporter: Val Sharp, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)
BuildID:    2001091303

If one clicks on an item in the menubar, e.g. File, and then clicks on 
non-client area, the menu closes and the titlebar shows window doesn't have 
focus. But subsequently the titlebar isn't repainted when focus (clicking on 
client area) is restored.

A partial repaint of the titlebar can be seen if the top of the Mozilla window 
partially overlaps some other window, e.g.: in Mozilla click File on menubar; 
click the other window, which then comes to the fore; click on Mozilla window, 
which then comes to the fore again; notice that the titlebar is only repainted 
where the window was obscured by the other window.

Reproducible: Always

Comment 1

17 years ago
an oldie.

*** This bug has been marked as a duplicate of 37540 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.