Open Bug 1034800 Opened 6 years ago Updated 5 years ago

ugly artifacts in default theme OR ui / User Interface design in Firefox 31.0 beta 7

Categories

(Core :: Graphics, defect)

31 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

UNCONFIRMED

People

(Reporter: darth.Serious, Unassigned)

Details

Attachments

(6 files)

ui elements show artifact upon re-draw after window-resize or when elements get focus (you hover on search bar or buttons, use dropdown, open menus)..

I have never encountered this since Firefox 5.0
how can i help?

i can further test if this persists in other Themes other than the default, and if it exists in Firefox builds for *n?x systems (I have Fedora and illumos-based OS'es)

probably this was introduced by the new interface starting with version 29/30/31?
Firefox-31-artifact-02 - Search bar
Attachment #8451217 - Flags: ui-review+
Attachment #8451217 - Attachment description: Firefox-31-artifact-04-highlight.JPG → Firefox-31-artifact-02 - Search bar
Attachment #8451217 - Flags: ui-review+
Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]:   annoying, shameful UI, not becoming of a mature browser, it's as if we're starting all over again
Attachment #8451220 - Flags: ui-review+
Attachment #8451220 - Flags: feedback+
Attachment #8451220 - Flags: approval-mozilla-beta?
Flags: needinfo?(nobody)
Attachment #8451222 - Flags: ui-review+
Attachment #8451222 - Flags: feedback+
Attachment #8451222 - Flags: approval-mozilla-release?
Attachment #8451222 - Flags: approval-mozilla-beta?
while appreciating filing a bug please do not abuse keyword/flag setting usage - thank you.
Attachment #8451220 - Flags: ui-review+
Attachment #8451220 - Flags: feedback+
Attachment #8451220 - Flags: approval-mozilla-beta?
Attachment #8451222 - Flags: ui-review+
Attachment #8451222 - Flags: feedback+
Attachment #8451222 - Flags: approval-mozilla-release?
Attachment #8451222 - Flags: approval-mozilla-beta?
Component: Shell Integration → Untriaged
Thanks! this has occurred at least since 31 beta 5,6 and 7 on the desktop..
Please try disabling hardware acceleration in Options → Advanced → General.
Component: Untriaged → Graphics
Flags: needinfo?(darth.Serious)
Product: Firefox → Core
+ Updating to latest 31.0 beta 9
+ disabling hardware acceleration in Options → Advanced → General
+ issue resolved

so, was this merely "hardware acceleration" issue? i don't see it on Linux builds, only on Windows 7
Flags: needinfo?(darth.Serious)
You need to log in before you can comment on or make changes to this bug.