Abook card is not modal, causing crashes when closing out of sequence

VERIFIED FIXED in M11

Status

defect
P3
major
VERIFIED FIXED
20 years ago
3 years ago

People

(Reporter: esther, Assigned: hangas)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Using 19990722 builds on win32, linux and mac ppc the Card - Edit view dialog is
not modal.  Because of this the user can open multiple cards or close the
Address Book window/Address Picker window while a card is still openend.  This
can cause crashes and possible lost data.  See bug 10291 for Address picker
crash scenario.  This crash also happens if done using the Address Book

1. Launch Messenger
2. Select Address Book from the Tasks menu
3. Select the Personal Address Book (have at least 3 cards in the Address Book)
4. Double-click on a card to open the card.
5. Click on the Address Book again to bring it up front or have focus.

Result: you can get focus of another window or dialog or menu
Expected: you can't get focus of another window or dialog or menu until you
dismiss the opened card.
QA Contact: lchiang → esther
Status: NEW → ASSIGNED
Depends on: 10255
Target Milestone: M9
Waiting for 10255.
Depends on: 9631
Target Milestone: M9 → M10
Bumping to M10, nothing I can do but wait for modal dialogs.
*** Bug 10291 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Modal dialogs landed a while ago, I turned on modal for the address book cards
and this bug is fixed.
Status: RESOLVED → REOPENED
Using win32 build 19990901 M10, Mac and Linux builsd 19990831 this is not quite
right yet. Reopening.
This doesn't completely work the same across all platforms yet:

When an Address book card is opened:

1. Mac is completely modal, no other windows can be brought to the front until
the card is dismissed.
2. Linux is partially modal, other windows can be brought to the front but no
actions can be done in any of them until the card is dismissed.
3. Win32 is marginally modal, only the Address Book is rendered not accesible
while a card is opened.  You can bring the Messenger window to the front, Click
New Msg and open messages.

This bug as stated in scenario only referred to the Address Book window but we
don't have platform parity regarding this yet per results stated above.
Reopening.
Resolution: FIXED → ---
Target Milestone: M10 → M11
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
The original bug here is fixed so marking resulution as fixed.  The secondary
issue from esther was one of platform parity with regard to how modal dialogs
work on the three different platforms.  Yesterday, German made the call that this
is the way we should keep it.  Sol agreed, and so we move on.  We leave the modal
dialogs working differently on each platform and in my opinion this is a testing
headache because on the Windows platform we will have to make sure that duplicate
copies of the same dialog are never brought to the front.
Status: RESOLVED → VERIFIED
Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.