dns migration creates tls session resumption problem

RESOLVED FIXED

Status

()

Core
Networking
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: briansmith, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

Telemetry probes SSL_RESUMED_SESSION and SSL_HANDSHAKE_TYPE are reporting that we're only doing session resumption in ~48% of TLS handshakes since Firefox 29. In Firefox 28 and previous versions, our resumption rate was 58%. I looked at the SSL_RESUMED_SESSION probe for Aurora 29, from the time period before bug 981447's patch was uploaded and the time after bug 981447's patch landed and that seems to clearly show that patch causing the 10% regression.

See bug 415196 for a potential solution.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Summary: Persistent 10% regression in TLS session resumption rate in in Firefox 29 → dns migration creates tls session resumption problem
Whiteboard: [necko-backlog]
You need to log in before you can comment on or make changes to this bug.