le-dictionnaire.com when entering a word, it doesn't return the definition.

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Bollar852, Unassigned, Mentored)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-fr] [js] [contactready], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8451314 [details]
Differences between Firefox and IE

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Access to the site and indicate the word of my choice in the appropriate field: "INDIQUEZ LE MOT DE VOTRE CHOIX".

Press ENTER.


Actual results:

This opens a tab with the home page of the website.

Note that the home page is malformed since the latest versions of Firefox.

This website certainly works until the 16.0.1 version of Firefox but not on the 30.


Expected results:

This should display definitions of the word.

Below the main field, there should be a list full of choices and an "OK" button.

The 3 words in the little bubble should not be shifted.

Comment 1

3 years ago
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4d567ebd2624
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130122 Firefox/21.0 ID:20130122115532
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/059c7e8541e2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130122 Firefox/21.0 ID:20130122123031
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4d567ebd2624&tochange=059c7e8541e2
Regressed by:
059c7e8541e2	Boris Zbarsky — Bug 828787. Stop allowing indexed expandos on windows. r=peterv
Blocks: 828787
Component: Untriaged → DOM
Product: Firefox → Core
Version: 30 Branch → 21 Branch
Quoting from the site JS:

  function MakeArray(n) {
    for (var i = 1; i <= n; i++) {
      this[i] = 0;
    }
    this.maxlen = n;
    this.len = 0;
    return this;
  }

this is then called like so:

  var engs = MakeArray(MAX_ENGINES);

which will invoke it with "this" set to the Window object.

I think this is just a bug in this site's script that should be fixed; if they want to create an array, they should do that.
Assignee: nobody → french
Status: UNCONFIRMED → NEW
Component: DOM → French
Ever confirmed: true
Product: Core → Tech Evangelism
Version: 21 Branch → Trunk

Comment 3

3 years ago
Tested and Confirmed on Mac OS X too.
Assignee: french → nobody
Component: French → Desktop
Whiteboard: [country-fr]

Updated

3 years ago
Summary: Bug with http://www.le-dictionnaire.com/ → le-dictionnaire.com when entering a word, it doesn't return the definition.

Updated

3 years ago
Mentor: kdubost@mozilla.com

Updated

3 years ago
Whiteboard: [country-fr] → [country-fr] [js] [contactready]

Comment 4

3 years ago
Hey guys, I made a quick fix for this site. That script that was there was like 12 years old. Now creating new javascript "objects" and assigning values to the new object instead of using 'this'. It works well in Firefox now. You should close this 'bug report' as it was not really a Firefox bug, but bad javascript which seems to be working anyway on most browsers.
Thanks Willy, it is indeed working now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.