Download directly to file, not to *.part

RESOLVED WONTFIX

Status

()

Firefox
Downloads Panel
--
enhancement
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Jan Skrasek, Unassigned)

Tracking

31 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140703154127

Steps to reproduce:

Start downloading video.


Actual results:

Firefox starts saving file into video.avi.part


Expected results:

Firefox starts saving file into video.avi

Few notes:
I wanna play unfinished downloaded file in video pleayer (km player), there is no reason to wait. I understand that this new behavior is not ideal for BFU, it could be configurable in about:config.

Updated

4 years ago
Severity: normal → enhancement

Comment 1

4 years ago
I expect this is wontfix, because:

- your usecase is niche (most of what people download aren't video files; most people don't care about watching them while they download; lots of software doesn't cope with doing that anyway; non-expert users would be confused because they wouldn't be able to tell if the download was finished; their media player might break / give up / crash halfway through the file if the download stalled...
- this wouldn't work if you configure the download manager pick a download location beforehand (because we want to start downloading immediately)
- introducing default-preffed-off behaviour for an edge-case like this probably involves significant code changes with a high risk of regressing/breaking (because default-preffed-off, so we won't notice) which will be hard to track down (because of it requiring an about:config change that people will forget they make, and which we then spend ages tracking down, because why does <whatever> work for person X but not for person Y)


... but I'll leave it to Paolo to make a decision.

You sound like you're an advanced enough user that you could probably create a shell watcher script or add-on that auto-symlinked part files to some other place where you could more easily open them in your favourite video player (which should be possible on linux even for the *.part extension'd files).
Component: Untriaged → Downloads Panel
Flags: needinfo?(paolo.mozmail)
OS: Windows 8.1 → All
Hardware: x86_64 → All
(Reporter)

Comment 2

4 years ago
The video use-case is primary, however not the only reason, another one is much more cleaner file list overview.

This was behavior of old Opera.

Comment 3

4 years ago
Thanks Gijs for a great summary of the reasons why we shouldn't support this use case in core Firefox.

Jan, thank you for reporting anyways. I think this use case could be well-suited to a dedicated video downloading add-on - you may try to search addons.mozilla.org, and it is possible that an add-on that does this already exists, or you can suggest an improvement to an existing add-on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(paolo.mozmail)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.