Crash in mozalloc_abort(char const* const) | NS_DebugBreak | nsDebugImpl::Abort(char const*, int) with AsyncShutdownTimer "Sqlite.jsm Waiting for connections to close"

RESOLVED FIXED in Firefox 32

Status

defect
--
major
RESOLVED FIXED
5 years ago
9 months ago

People

(Reporter: ashughes, Assigned: Yoric)

Tracking

(Blocks 1 bug, {crash})

unspecified
Firefox 33
Dependency tree / graph

Firefox Tracking Flags

(firefox32 fixed, firefox33 fixed)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

See also bug 944873 comment 51.

1. Load https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort%28char%20const*%20const%29%20|%20NS_DebugBreak%20|%20nsDebugImpl%3A%3AAbort%28char%20const*%2C%20int%29#tab-reports
2. Click "Change columns in this table" or scroll to the bottom of the page
3. Select "AsyncShutdownTimeout" from the "Available columns" list 
4. Click ">>" to add it to the list of "Chosen columns"
5. Click "Save and Reload"
6. Find in page "Sqlite.jsm Waiting for connections to close"

As near as I can tell this has only been reported once so far:
https://crash-stats.mozilla.com/report/index/0e49ffb0-9749-4c93-82bc-8a89f2140627

Unfortunately, I don't know a good way to query crashstats to filter out only the crashes with this AsyncShutdownTimer message so I cannot be certain about the volume.
Reporter

Updated

5 years ago
Blocks: 944873
Depends on: 1034726
I suspect that this single crash was actually caused by a misbehaving add-on. Waiting for bug 1034726 and more signatures.
Actually, there are 133 of these crashes on Nightly, 138 on Aurora, none on Beta. We need to investigate quickly.
Severity: normal → major
Instrumenting the shutdown to find out what's wrong. It would be really good if we could get this fixed in Aurora before the uplift (next week, iirc).
Assignee: nobody → dteller
Attachment #8451603 - Flags: review?(mak77)
Attachment #8451603 - Flags: review?(gps)
I may have found the issue. This does not remove the need for the other patch, which should prove useful in case there is more than one issue or in case we have misbehaving clients, but I hope that this fixes the topcrasher in Aurora and Nightly.

Self-reviewing given that 1/ it's a typo fix; 2/ none of the other reviewers are available at the moment.
Attachment #8451651 - Flags: review+
Same typo, but fixing on the other side. Still only 5 chars, still self-reviewing.
Try: https://tbpl.mozilla.org/?tree=Try&rev=6e7abb2f9336
Attachment #8451651 - Attachment is obsolete: true
Attachment #8451700 - Flags: review+
Comment on attachment 8451603 [details] [diff] [review]
More logging for Sqlite AsyncShutdown

Review of attachment 8451603 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't realize you could log extra state like this. That's pretty cool.

Also, I just glanced at AsyncShutdown.jsm for the first time. It's brilliant. I can't wait for us to apply the same concepts to startup as well. Lazy service initialization FTW!
Attachment #8451603 - Flags: review?(mak77)
Attachment #8451603 - Flags: review?(gps)
Attachment #8451603 - Flags: review+
Comment on attachment 8451700 [details] [diff] [review]
1. Fixing fatal typo in Sqlite.jsm, v2

Approval Request Comment
[Feature/regressing bug #]: bug 1028887
[User impact if declined]: unpredictable shutdown freeze/crashes
[Describe test coverage new/current, TBPL]: This is just a typo fix. Just landed on m-c.
[Risks and why]: None.
[String/UUID change made/needed]: None.
Attachment #8451700 - Flags: approval-mozilla-aurora?
Comment on attachment 8451603 [details] [diff] [review]
More logging for Sqlite AsyncShutdown

Approval Request Comment
[Feature/regressing bug #]: Bug 1028887.
[User impact if declined]: This patch introduces logging that should help us fix unpredictable shutdown freeze/crash if the other patch is not sufficient.
[Describe test coverage new/current, TBPL]: Just landed on m-c.
[Risks and why]: This patch just adds logging.
[String/UUID change made/needed]: None.
Attachment #8451603 - Flags: approval-mozilla-aurora?
(In reply to Gregory Szorc [:gps] from comment #7)
> Comment on attachment 8451603 [details] [diff] [review]
> More logging for Sqlite AsyncShutdown
> 
> Review of attachment 8451603 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I didn't realize you could log extra state like this. That's pretty cool.
> 
> Also, I just glanced at AsyncShutdown.jsm for the first time. It's
> brilliant. I can't wait for us to apply the same concepts to startup as
> well. Lazy service initialization FTW!

Thanks :)
Comment on attachment 8451603 [details] [diff] [review]
More logging for Sqlite AsyncShutdown

We want logging. Approved!
Attachment #8451603 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8451700 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/a3dce4eedb9a

Looks like the typo fix was for code that doesn't live on Aurora, so I didn't land that patch. The other one required some rebasing, so please take a look to make sure everything's OK with what landed.
This looks good, thanks.
Apparently, according to http://yoric.github.io/are-we-shutting-down-yet-/&sample_size=500#Sqlite.jsm%20shutdown%20blocker, we do not have recent occurrences of the bug. Marking as fixed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [leave open]
Target Milestone: --- → Firefox 33

Updated

9 months ago
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.