Location bar history list messes up file URLs without file:// prefix

VERIFIED DUPLICATE of bug 92132

Status

SeaMonkey
Location Bar
VERIFIED DUPLICATE of bug 92132
16 years ago
9 years ago

People

(Reporter: Stephen Moehle, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
File paths typed in the location bar are not kept in the location bar history
properly.  They are stored as http:// URLs.

To reproduce:

In the location bar, enter a file URL as a path without the file:// prefix such as:

/home/user/web/index.html

Mozilla loads the page and changes the location bar to show:

file:///home/user/web/index.html

If you dropdown the menu for the location bar and look at the location bar
history, you see that the URL is listed there with as http:// rather than
file://.  If you pick this entry, nothing happens.  No error messages or
anything which is probably a separate bug of Mozilla being stubbornly unhelpful.

Tested with Mozilla trunk build 2001100606 on Linux.
ccing hewitt.  Sounds like this is either his or History:Global.

Comment 2

16 years ago
Confirming on linux with 0.9.5 and a recent cvs build (1025 or so).

-> URL bar for a first cut
Assignee: hyatt → hewitt
Status: UNCONFIRMED → NEW
Component: XP Toolkit/Widgets → URL Bar
Ever confirmed: true
QA Contact: jrgm → claudius

Comment 3

16 years ago
I take it back; this is a dup.

*** This bug has been marked as a duplicate of 92132 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.