If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Impossible to go back after visiting this site

RESOLVED FIXED in mozilla0.9.9

Status

()

Core
Document Navigation
--
major
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Niels Aufbau, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
mozilla0.9.9
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Steps to reproduce:
1. Go to http://windowsupdate.microsoft.com/default.htm?Page=productupdates. 
(This page appears blank in Mozilla.)
2. Hit the back button (once or several times quickly).

Actual result: the page appears to reload.
Expected result: Mozilla goes back to this bug report.

Note: http://supportservices.msn.com/, and possibly other MSN pages, bring up a
dialog warning you to switch to Internet Explorer or "some Web pages may not
display properly on your monitor".  Clicking "OK" in the dialog takes you to the
URL above.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Target Milestone: --- → mozilla0.9.6
Target Milestone: mozilla0.9.6 → mozilla0.9.9
I can't reproduce this anymore. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
I can still reporoduce this bug.  I'm using 2002012403 on Windows 98.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
what version of netscape or build of mozilla you are using?
(Reporter)

Comment 4

16 years ago
I'm using 2002012403 (trunk) on Windows 98.  One thing has changed: if I hit the
back button twice *quickly*, I can get back to this bug report.
The page does a document.write() which is now supported by session history. (See
bug 35340 which was fixed minutes ago).   I'm able to go back to this bug report
with that patch. Please try tomorrow build and let me know what you find. 

Claudius: I would also like you to give this a try. Thanks.
(Reporter)

Comment 6

16 years ago
Using build 2002020103, I can leave the page simply by pressing the back button.
However, the URL bar now shows wyciwyg://0//default.htm?Page=productupdates
after I click on the link.
That is because the site is doing a JS document.write(),  which triggers the 
wyciwyg protocol (What You Cache Is What You Get) to kick in. I checked in that
feature last week. 
With the implementation of wyciwyg protocol, this bug is no longer reproducible.
If browsing to the site shows up a  blank  page, that could be because the page
has something specific to IE that mozilla is not able to render.  Another bug
addresses that issue. The appearance of wyciwyg on the urlbar indicates that
there is a JS document.write() in the page.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.