Ctrl+clicking, shift-clicking, alt-clicking, meta-clicking a link selects a lot of things

RESOLVED FIXED in Firefox 33

Status

()

Core
Selection
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Guilherme Lima, Assigned: Kestrel)

Tracking

(Blocks: 1 bug, {regression})

33 Branch
mozilla33
regression
Points:
---

Firefox Tracking Flags

(firefox33+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

45.21 KB, image/png
Details
(Reporter)

Description

4 years ago
Created attachment 8451410 [details]
Screenshot of the bug

Ctrl+clicking a link gives the same result as ctrl+clicking outside the link - selecting a lot of things around.

I suspect it's a regression from bug 378775.
Nightly regressed that day - version Firefox/33.0 ID:20140704030208 CSet: e8df6826a571

I'm on a notebook - don't know if makes any difference - don't have a mouse to test with.

I'm filling this bug under Untriaged hoping someone else can reproduce and confirm that bug 378775 is the culprit.

Updated

4 years ago
Blocks: 378775
Status: UNCONFIRMED → NEW
status-firefox33: --- → affected
tracking-firefox33: --- → ?
Component: Untriaged → Selection
Ever confirmed: true
Product: Firefox → Core
Version: Trunk → 33 Branch

Updated

4 years ago
Keywords: regression

Comment 1

4 years ago
Ctrl-clicking does <table> cell selection - after bug 378775 it happens for links in <table>s in addition to opening the link. The open-link-in-new-tab code should prevent the event from leaking.

Comment 2

4 years ago
Similarly, Shift+clicking a link selects a range of text in addition to opening the link in a new window.
Lets track this for now.
tracking-firefox33: ? → +

Comment 4

4 years ago
It's worth noting that this doesn't just affect literal <table>
elements, as it also happens for pages using CSS 'display: table-cell;'
for styling.

Comment 5

4 years ago
Seeing this in OS X as well. [Cmd + click]

Updated

4 years ago
Duplicate of this bug: 1037473

Updated

4 years ago
Summary: Ctrl+clicking a link selects a lot of things → Ctrl+clicking, shift-clicking, alt-clicking, meta-clicking a link selects a lot of things

Updated

4 years ago
Duplicate of this bug: 1037773
Duplicate of this bug: 1038054
Kestrel, can you take this bug since your patch caused it?
Flags: needinfo?(kestrel)
(Assignee)

Comment 10

4 years ago
Created attachment 8458141 [details] [diff] [review]
bug1035036.patch

Added exception for ctrl and shift modifiers so that opening links gets priority over selecting text.
Attachment #8458141 - Flags: review?(enndeakin)
Flags: needinfo?(kestrel)

Comment 11

4 years ago
It would be nice if we got a test for this as well, so that we don't regress it in the future.

Comment 12

4 years ago
You might want to check Cmd too, since on Mac it acts like Ctrl for the purposes of selection and link-dispatching.

Comment 13

4 years ago
Neil, any chance you could review this soon please?  This bug is making using Nightly really painful for me... :(

Comment 14

4 years ago
Nevermind, it looks like the patch was backed out!

Comment 15

4 years ago
Comment on attachment 8458141 [details] [diff] [review]
bug1035036.patch

You will also want to check for IsMeta() as well.
Attachment #8458141 - Flags: review?(enndeakin) → review-
(Assignee)

Updated

4 years ago
Attachment #8458141 - Attachment is obsolete: true
Kestrel, could you help here?
Flags: needinfo?(kestrel)
(Assignee)

Comment 17

4 years ago
Solution was posted in bug 378775 using a different approach that delays selection.
Flags: needinfo?(kestrel)
Neil, could you point me where the backout has been done (Ehsan mentioned it in comment #14)? I would like to request the same for 33 (if this bug still occurs).
I don't see the bug 378775 landing in 33.

Thanks
Flags: needinfo?(enndeakin)

Comment 19

4 years ago
This is a regression from bug 378775, of which I am only the reviewer.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(enndeakin)
Resolution: --- → FIXED
(In reply to Sylvestre Ledru [:sylvestre] from comment #18)
> Neil, could you point me where the backout has been done (Ehsan mentioned it
> in comment #14)? I would like to request the same for 33 (if this bug still
> occurs).
> I don't see the bug 378775 landing in 33.
> 
> Thanks

It landed (and was backed out) prior to the previous uplift.
https://bugzilla.mozilla.org/show_bug.cgi?id=378775#c49
Assignee: nobody → kestrel
status-firefox33: affected → fixed
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.