gaiatest test_endurance_camera_photo.py fails at session_capability attribute

RESOLVED DUPLICATE of bug 1033033

Status

Firefox OS
Gaia::UI Tests
P1
blocker
RESOLVED DUPLICATE of bug 1033033
3 years ago
3 years ago

People

(Reporter: tkundu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #1033033 +++

test_endurance_camera_photo.py fails with following logs :


  if self.device_manager:
  File "/net/cros-bs-p4/local/mnt/workspace/tkundu/kk_36/out/host/marionette/client/marionette/marionette_auto_venv/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/runner/mixins/b2g.py", line 50, in device_manager
    return self.get_device_manager()
  File "/net/cros-bs-p4/local/mnt/workspace/tkundu/kk_36/out/host/marionette/client/marionette/marionette_auto_venv/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/runner/mixins/b2g.py", line 43, in get_device_manager
    capabilities = self.marionette.session_capabilities
AttributeError: 'NoneType' object has no attribute 'session_capabilities'
(marionette_auto_venv)tkundu@tkundu-linux:/net/cros-bs-p4/local/mnt/workspace/tkundu/kk_36$ 
(marionette_auto_venv)tkundu@tkundu-linux:/net/cros-bs-p4/local/mnt/workspace/tkundu/kk_36$ 


I found that we are using marionette_client-0.7.10-py2.7.egg package and this python package contains patch from bug 1019043

If we use same marionette_client-0.7.10-py2.7.egg but revert bug 1019043 from that python package (marionette_client-0.7.10-py2.7.egg) then issue goes away.


Issue is not visible for all gaiatest . 
But some gaiatest like test_endurance_camera_photo.py gives above error.
This is a regression .



FFOS 2.0 gaia repo is fixed by bug 1033033 . 

But we still need marionette client 0.7.11 to fix this gaiatest error [1] 
[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1033033#c12
blocking-b2g: --- → 2.0?
Flags: needinfo?(zcampbell)

Comment 1

3 years ago
Dupe
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(zcampbell)
Resolution: --- → DUPLICATE
Duplicate of bug: 1033033

Updated

3 years ago
blocking-b2g: 2.0? → ---
No longer depends on: 1033033
You need to log in before you can comment on or make changes to this bug.