Closed Bug 1035105 Opened 9 years ago Closed 9 years ago

Timestamp conversion to time units errata in webrtcOMXH264VideoCodec

Categories

(Core :: WebRTC: Audio/Video, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1030112

People

(Reporter: opatinobugzilla, Unassigned)

Details

Attachments

(1 file)

When calling function mOMX->Encode() in file WebrtcOMXH264VideoCodec.cpp, timestamp conversion to us is wrongly computed multiplying by 100011/90. It is an errata and should be *1000ll/90.
Attached patch proposed patchSplinter Review
Proposed patch. By mistake two '1's were added instead of LLs
Attachment #8451498 - Flags: review?(paul)
Good eye! However it's already fixed by Randell's patch in bug 1030112 attachment 8450208 [details] [diff] [review]. :-)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Comment on attachment 8451498 [details] [diff] [review]
proposed patch

Review of attachment 8451498 [details] [diff] [review]:
-----------------------------------------------------------------

Canceling the review since this is already fixed elsewhere, but thank you anyways !
Attachment #8451498 - Flags: review?(paul)
You need to log in before you can comment on or make changes to this bug.