Intermittent Homescreen UI Tests failures: test_homescreen_launch_app.TestLaunchApp.test_launch_app

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: AndreiH, Assigned: AndreiH)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Updated

4 years ago
Summary: Bug 1017101 - Intermittent Homescreen UI Tests failures: test_homescreen_launch_app.TestLaunchApp.test_launch_app → Intermittent Homescreen UI Tests failures: test_homescreen_launch_app.TestLaunchApp.test_launch_app
(Assignee)

Updated

4 years ago
Priority: -- → P1
(Assignee)

Comment 1

4 years ago
Created attachment 8451565 [details] [review]
PR https://github.com/mozilla-b2g/gaia/pull/21446
Attachment #8451565 - Flags: review?(florin.strugariu)
Attachment #8451565 - Flags: review?(florin.strugariu) → review+
(Assignee)

Comment 3

4 years ago
I cannot reproduce this locally, but I am pretty sure that the notification is covering up the app while scrolling into view, so we can add a wait for the notification to not be displayed and see the results.
(Assignee)

Updated

4 years ago
Assignee: nobody → andrei.hutusoru
I ran this test locally on desktop b2g and I was able to reproduce the failure. 
I watched the test while running and I noticed that the scroll is done before the notification dissapears, so the notification is covering the app, as stated in comment 3.
A wait for the notification not to be displayed  will be a good fix.
(Assignee)

Comment 5

4 years ago
Created attachment 8452248 [details] [review]
FIX PR https://github.com/mozilla-b2g/gaia/pull/21449
Attachment #8452248 - Flags: review?(zcampbell)
Attachment #8452248 - Flags: review?(florin.strugariu)

Comment 6

4 years ago
Comment on attachment 8452248 [details] [review]
FIX PR https://github.com/mozilla-b2g/gaia/pull/21449

r-, functionally fine just need to rename the variables.
Attachment #8452248 - Flags: review?(zcampbell)
Attachment #8452248 - Flags: review?(florin.strugariu)
Attachment #8452248 - Flags: review-
(Assignee)

Comment 7

4 years ago
Comment on attachment 8452248 [details] [review]
FIX PR https://github.com/mozilla-b2g/gaia/pull/21449

Updated!
Attachment #8452248 - Flags: review- → review?(zcampbell)

Comment 8

4 years ago
Comment on attachment 8452248 [details] [review]
FIX PR https://github.com/mozilla-b2g/gaia/pull/21449

r+ like!
Attachment #8452248 - Flags: review?(zcampbell) → review+

Comment 9

4 years ago
Nice fix Andrei!

Merged:
https://github.com/mozilla-b2g/gaia/commit/210861212a1dbbf442442cfb3c99f3248d2fc5e5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.