webconsole "aSourceURL is undefined" error when calling 'console.log(XMLDocument)'

VERIFIED FIXED in Firefox 34

Status

()

Firefox
Developer Tools: Console
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: pbro, Assigned: Sami Jaktholm)

Tracking

unspecified
Firefox 34
Points:
---

Firefox Tracking Flags

(firefox34 verified, firefox35 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8451636 [details]
test.html

The webconsole throws the following error in the browser console with the attached HTML test case: "aSourceURL is undefined utils.js:198"

STR:
- Open the attached HTML test case (tested in Aurora)
- Open the webconsole
- Open the browser console
- Click on the XMLDocument link in the console

=> The XMLDocument object isn't expanded in the object inspector and the error is thrown in the browser console
(Reporter)

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86 → All

Updated

4 years ago
See Also: → bug 1036218
(Assignee)

Comment 1

4 years ago
Created attachment 8459126 [details] [diff] [review]
console-locationless-document-nodes.patch

Here's a patch that only adds location to DOCUMENT_NODE if it has one when a DOMNode is inspected in the VariablesView. The patch contains a test case for this bug.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=1846e5aa8d4c
Attachment #8459126 - Flags: review?(rcampbell)
Comment on attachment 8459126 [details] [diff] [review]
console-locationless-document-nodes.patch

Review of attachment 8459126 [details] [diff] [review]:
-----------------------------------------------------------------

ok! thanks for this.

::: browser/devtools/webconsole/test/head.js
@@ +48,5 @@
> + * Define an async test based on a generator function
> + */
> +function asyncTest(generator) {
> +  return () => Task.spawn(generator).then(null, ok.bind(null, false)).then(finishTest);
> +}

surprised we didn't have one of these in here already.
Attachment #8459126 - Flags: review?(rcampbell) → review+
(Assignee)

Updated

4 years ago
Assignee: nobody → sjakthol
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/1006faf77958
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]

Updated

4 years ago
Duplicate of this bug: 1036218
https://hg.mozilla.org/mozilla-central/rev/1006faf77958
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
QA Whiteboard: [qa-]
QA Whiteboard: [qa-] → [good first verify]

Comment 6

3 years ago
I was able to reproduce this bug on Nightly 33.0a1 (2014-07-07), using Windows 7 x64.

Verified fixed on Windows 7 x64, Mac OSX 10.9.5 and Ubuntu 14.04 x86 using Nightly 35.0a1 (2014-10-07) and Aurora 34.0a2 (2014-10-07).

This fix can be marked as verified.

[bugday-20141008]
(In reply to vasilicamihasca from comment #6)
> I was able to reproduce this bug on Nightly 33.0a1 (2014-07-07), using
> Windows 7 x64.
> 
> Verified fixed on Windows 7 x64, Mac OSX 10.9.5 and Ubuntu 14.04 x86 using
> Nightly 35.0a1 (2014-10-07) and Aurora 34.0a2 (2014-10-07).
> 
> This fix can be marked as verified.
> 
> [bugday-20141008]

Thank you for your work! Marking this as Verified.
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify] → [good first verify][bugday-20141008]
status-firefox34: --- → verified
status-firefox35: --- → verified
You need to log in before you can comment on or make changes to this bug.