Overscrolling the home-screen doesn't transform the scroll indicator like it does elsewhere

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

Trunk
All
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 fixed)

Details

(Whiteboard: [2.0-VH-bug-bash])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
If you overscroll on the home-screen, the scroll indicator stays in the same place and doesn't indicate overscroll in any way.

This is contrary to the same thing in the Firefox Marketplace, for example, where the scroll indicator is transformed along with the page.

I don't feel strongly about either behaviour, but I feel we should be consistent.
blocking-b2g: --- → backlog
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Whiteboard: [2.0-VH-bug-bash]
This will probably be less noticeable with the new "stretch" overscroll but it's still something we should fix.
Comment hidden (typo)
I looked into this briefly and the layer tree dumps for the marketplace are kind of surprising. While in overscroll there, the scrollbar doesn't show up as a separate layer at all, it seems to just get flattened into the content or something. While not in overscroll though it does appear as a separate layer. In the homescreen, by contrast, the scrollbar is always a separate layer. That might explain why the scrollbars transform with the content in the marketplace.
Created attachment 8488814 [details]
Layer dumps from homescreen and marketplace w/ and w/o scrollbar layer
Comment hidden (typo)
I tried this again on the latest code and now not only does everything seem to be layerized correctly, but also I can't reproduce the original problem. The overscroll transform seems to affect the scrollbar both on the homescreen and in the marketplace.

I tried backing out bug 1061327 locally to see if that was what fixed it but it wasn't. So I'm not sure what fixed it, but I can bisect if we want to uplift the fix. For now I'll just close this as WFM.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: --- → fixed
Resolution: --- → WORKSFORME
Ah, I think it might have been fixed by gaia-side changes in bug 1038178. Rolling back my gaia to a version just before that landed made the homescreen scrollbar remain unaffected by the overscroll stretch.
Depends on: 1038178
(Reporter)

Comment 8

4 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> Ah, I think it might have been fixed by gaia-side changes in bug 1038178.
> Rolling back my gaia to a version just before that landed made the
> homescreen scrollbar remain unaffected by the overscroll stretch.

Yes, this would be it - I don't know if you want to re-title this bug to be about the more general case of overscroll on sub-frames, but I don't think it's important.
The part 2 patch on bug 1043859 makes all root-level scrollbars be unaffected by overscroll as well. That makes them consistent with subframe scrollbars. That's easier (and more future-compatible) than giving them all overscroll.
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.