Closed Bug 1035266 Opened 8 years ago Closed 8 years ago

Landscape apps leave slivers down the side of portrait apps

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED DUPLICATE of bug 1034347
2.0 S6 (18july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: cwiiis, Assigned: etienne)

Details

(Whiteboard: [2.0-VH-bug-bash][systemsfe])

Attachments

(1 file)

STR:

1- Open an app that supports landscape mode
2- Rotate to landscape
3- Press the home-button

Expected:

You see the home-screen, and nothing else

Actual:

The home-screen appears, but a small line appears down the top-left edge of the screen.


I discovered this bug during the 2.0 bug bash, but I can't reproduce it using a master build. Seems like this has been fixed and there might be something we can uplift (or perhaps it already has been uplifted and this bug is invalid).
Needs a video.
Keywords: qawanted
Whiteboard: [2.0-VH-bug-bash][systemsfe]
This is today's 2.0 homescreen with Cut the rope running in the background. Everytime that this app is running, this blank line is on the homescreen.

By the way, the line on the screenshot is less obvious that the one on the real screen.
I can reproduce this in 2.1, it's just, for whatever reason, harder.
Assignee: nobody → gduan
blocking-b2g: 2.0? → 2.0+
Hi Etienne,
I saw bug 1034347 has fixed it on master branch, do you mind to take a look at this bug?
Flags: needinfo?(etienne)
Bug 1034347 should fix this, taking and I'll confirm/mark it as duplicate once 1034347 is resolved.
Assignee: gduan → etienne
Flags: needinfo?(etienne)
Target Milestone: --- → 2.0 S6 (18july)
Yep, this was caused by a hack, removed as part of bug 1034347, which is also 2.0+ so resolving duplicate here.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1034347
Actually I believe this was caused by bug 1027231.
You need to log in before you can comment on or make changes to this bug.