Closed Bug 1035323 Opened 7 years ago Closed 7 years ago

remove redundant null-checks for DetailedGlyphStore

Categories

(Core :: Graphics: Text, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: jfkthame, Assigned: jfkthame)

Details

Attachments

(1 file)

The DetailedGlyphStore used in shaped-text records (shaped-word, text-run) uses infallible nsArrays, so there's no need for a bunch of null-checks.
Attachment #8451768 - Flags: review?(jdaggett)
(Also removed gfxTextRun::AllocateDetailedGlyphs, which was a redundant duplicate of gfxShapedText::AllocateDetailedGlyphs.)
Attachment #8451768 - Flags: review?(jdaggett) → review+
You need to log in before you can comment on or make changes to this bug.