Closed Bug 103533 Opened 18 years ago Closed 18 years ago

Cannot hide table that has attribute style

Categories

(Core :: Layout: Tables, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
mozilla1.1alpha

People

(Reporter: bugzilla, Assigned: pierre)

References

Details

(Keywords: testcase)

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20011003
BuildID:    20011003

Cannot hide table that has inline css (style-attribute). 
See testcase, 2 tables in that document. Both should be hidden.
The first one is hidden, because the css is not set with the style-attribute.

Reproducible: Always
Steps to Reproduce:
1. Run testcase
I see this on Linux with build 2001-10-03-08 as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Oh, replacing <table> with <div> makes the bug disappear.
Keywords: testcase
In the table with style=, during painting of the table, the style visibility is 
visible. I don't think table code is changing visibility anywhere, so maybe 
there are some style rules that are doing it involving tables. -->pierre
Assignee: karnaze → pierre
It is a regression from the rule tree landing (bug 91672).  Apparently we can no 
longer change by script the style of tables that have a style attribute.
Blocks: 91672
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
Priority: -- → P3
Bug 90960 could be related to this one.
Keywords: mozilla1.0
Noticed that the second table actually is hidden is you hide it using:
document.getElementById("b").setAttribute("style","visibility:hidden;");

instead of:
document.getElementById("b").style.visibility = "hidden";

Dont know if this helps...
Moving to Mozilla1.1. Engineers are overloaded with higher priority bugs.
Target Milestone: mozilla1.0 → mozilla1.1
This works for me with build 20020219 Windows 2000. :-)
Yep.  This got fixed sometime between Feb 8 and Feb 17.  Someone brave could try
to figure out exactly why... :)

worksforme on linux build 2002-02-20-08 (and 02-17-21) as well.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
This got fixed between 2002-02-15-08 and 2002-02-16-21, to be exact.

There are changes to TableLayoutStrategy in that range, as well as changes to
the CSSFrameConstructor's construction of table stuff, changes to the parser
affecting tables, all in that range. I  bet the CSSFrameConstructor is
responsible.
You need to log in before you can comment on or make changes to this bug.