Closed Bug 1035369 Opened 5 years ago Closed 5 years ago

When registering, send "simplePushURL" parameter rather than "simple_push_url"

Categories

(Hello (Loop) :: Client, defect, P3)

defect

Tracking

(firefox34 fixed)

RESOLVED FIXED
mozilla34
Tracking Status
firefox34 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

This was altered in bug 1029580 to make parameter names more consistent. Bug 1032966 implies the old parameter will get removed at some stage, hence we should swap to the new one.
Priority: P1 → P2
Whiteboard: [blocked, waiting for new server deployment with appropriate params]
Target Milestone: mozilla33 → mozilla34
This is likely a trivial patch which makes things simpler for the server folks.  Mark -- am I right?
Flags: needinfo?(standard8)
Priority: P2 → P1
I think this is clean up.  So marking it as such.  I'll talk with Mark to confirm on Monday.
Priority: P1 → P3
This does the necessary update for the parameter name, and extends the tests to ensure the parameter is actually sent.
Attachment #8463909 - Flags: review?(mdeboer)
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #2)
> I think this is clean up.  So marking it as such.  I'll talk with Mark to
> confirm on Monday.

Yep, this is clean up, patch now attached ;-)
Assignee: nobody → standard8
Flags: needinfo?(standard8)
Whiteboard: [blocked, waiting for new server deployment with appropriate params] → [p=1]
Comment on attachment 8463909 [details] [diff] [review]
Update the parameter name for the push url when registering with the Loop server to match with the latest version of the API.

Review of attachment 8463909 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! Thanks!

(xpcshell try run on a single, low-load server would be appreciated)
Attachment #8463909 - Flags: review?(mdeboer) → review+
(In reply to Mike de Boer [:mikedeboer] from comment #5)
> (xpcshell try run on a single, low-load server would be appreciated)

https://tbpl.mozilla.org/?tree=Try&rev=b54fdf6bde93
https://hg.mozilla.org/mozilla-central/rev/af885bfee5f3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified fixed in today's Nightly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Contact: anthony.s.hughes
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #9)
> Verified fixed in today's Nightly.

Sorry, I commented in the wrong bug. I don't think this needs QA testing. Please needinfo me to request testing.
Status: VERIFIED → RESOLVED
Closed: 5 years ago5 years ago
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.