Closed Bug 1035480 Opened 5 years ago Closed 5 years ago

Add new locales to Gaia and get the same list on 2.0

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86_64
Linux
defect
Not set

Tracking

(b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S6 (18july)
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: tchevalier, Assigned: tchevalier)

Details

Attachments

(2 files)

46 bytes, text/x-github-pull-request
timdream
: review+
Pike
: feedback+
Details | Review
46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review
We need to add new locales to 2.0 and 2.1. Let's also take the opportunity to uniform the list between the two branches.
We'll start adding new locales to 2.1 only as we branch out gaia-l10n on July 20th.

So if there is no partner request for locales on 2.0, I'd say this is the last uplift to 2.0.
Attached file Master PR
Attachment #8451977 - Flags: feedback?
Comment on attachment 8451977 [details] [review]
Master PR

It seems Stas needs en-GB, even if incomplete, is that okay for you?
Attachment #8451977 - Attachment description: Master PR → Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/21468
Attachment #8451977 - Flags: feedback? → feedback?(l10n)
Attachment #8451977 - Attachment description: Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/21468 → Master PR
Attached file 2.0 PR
Assignee: nobody → tchevalier
Status: NEW → ASSIGNED
Attachment #8451977 - Flags: feedback?(l10n) → feedback+
Axel, do we also need to add these new locales to the keyboard layouts mapping?

https://github.com/mozilla-b2g/gaia/blob/fc8a1232c5bb519539c76ddda72bd4fbaf47278a/build/config/keyboard-layouts.json
Flags: needinfo?(l10n)
Guess so, first time I see that file.
Flags: needinfo?(l10n)
Theo, can you create an updated patch here?
Flags: needinfo?(tchevalier)
Please let me know how the three S. African languages (Afrikaans, Zulu and Xhosa) will make it into the build and to the language menu. The translators have been doing this work in Pootle with Dwayne, but I need detailed instructions on what, if anything, they will need to do to get strings in the right place for 2.0; have them appear on the Flame devices they have; etc. Thanks!
Comment on attachment 8451977 [details] [review]
Master PR

Oops, yes.
I was wondering if we had to fallback to another layout for af/zu since we don't have dedicated layout for them, but let's land what we have.
Attachment #8451977 - Flags: review?(timdream)
Flags: needinfo?(tchevalier)
Attachment #8451979 - Flags: review?(timdream)
Thanks Theo! Really appreciate your help! :)
(In reply to Théo Chevalier [:tchevalier] from comment #8)
> I was wondering if we had to fallback to another layout for af/zu since we
> don't have dedicated layout for them, but let's land what we have.

It seems the case for other locales: as, bn-BD, cy, etc.
Comment on attachment 8451979 [details] [review]
2.0 PR


[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Adding requested locales for 2.0 (af and zu)
[User impact] if declined: missing locales
[Testing completed]: tested on master with Flame
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8451979 - Flags: approval-gaia-v2.0?(bbajaj)
Also mapped "da" layout with "da" locale on 2.0, as it's on master and we already have the da layout on 2.0.
Comment on attachment 8451977 [details] [review]
Master PR

I am rubberstamp this assuming this is the mapping you want.

Please note that |en| layout is actually points to en-US dictionary, e.g. it will attempt to "correct" the spelling of |colour| to |color|.

We can always file a follow-up to get a en-GB layout I think.
Attachment #8451977 - Flags: review?(timdream) → review+
Attachment #8451979 - Flags: review?(timdream) → review+
Thanks Tim!
Yeah, en-GB layout could be a follow-up
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/387629e1f65c7af2f698ff4ade6b425b1d437e2c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S6 (18july)
Attachment #8451979 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
You need to log in before you can comment on or make changes to this bug.