If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

directory viewer doesn't retain scroll position

VERIFIED DUPLICATE of bug 96230

Status

()

Core
Document Navigation
VERIFIED DUPLICATE of bug 96230
16 years ago
9 years ago

People

(Reporter: Leston Buell, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
mozilla0.9.5
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If you're viewing an ftp directory with a lot a files in it, if you click on a
subdirectory and then hit BACK, the scroll position is not remembered. You will
be at the top of the directory again.

I hit this all the time on the Mozilla nightly builds directory:
<ftp://ftp.mozilla.org/pub/mozilla/nightly>.

Using Linux trunk build 2001-10-03-08.
confirming. -> session history

This could be because of the interesting way in which the channel's content type
is set, I guess, but it ends up as html.
Assignee: pchen → radha
Status: UNCONFIRMED → NEW
Component: XP Apps → History: Session
Ever confirmed: true
QA Contact: sairuh → claudius
Actually, I can reproduce this in 0.9.4, before my dirviewer rewrite went in,
and without the content type hack (at least for the html view). So thats not it.
Bug 96230 has a patch attached that fixes this problem. 

*** This bug has been marked as a duplicate of 96230 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla0.9.5
Verif. DUPE
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.