Closed Bug 1035706 Opened 8 years ago Closed 7 years ago

[e10s] "tilt toggle" gcli command isn't e10s compatible

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

defect
Not set
normal

Tracking

(e10s+)

RESOLVED DUPLICATE of bug 937166
Tracking Status
e10s + ---

People

(Reporter: pbro, Unassigned)

References

Details

(Whiteboard: [e10s-m7])

While working on bug 875871 (specifically child bug 1034601) to have our devtools tests pass in e10s mode, I realized that when the toolbox starts, a tilt-related error is thrown in the console:

ERROR resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/tilt/tilt-utils.js:565 - TypeError: aWindow.QueryInterface is not a function

My best guess is that this error comes from tilt-commands.js in the isChecked function property of the "tilt toggle" command.
isChecked is probably being executed by the toolbox options panel to check/uncheck the 3D view checkbox.
Hmm, this might in fact be a gcli bug after all. isChecked is being executed here:
http://mxr.mozilla.org/mozilla-central/source/browser/devtools/shared/DeveloperToolbar.jsm#157
'target' is probably a cross-process object wrapper that doesn't have the QueryInterface property.
Blocks: dte10s
Component: Developer Tools: 3D View → Developer Tools: Graphic Commandline and Toolbar
FWIW, Tilt isn't remoted yet: 937166
My current plans for GCLI are that we should be able to do:

 {
   name: "tilt toggle",
+  process: "page",
   buttonId: "command-button-tilt",
   buttonClass: "command-button command-button-invertable",
   tooltipText: gcli.lookup("tiltToggleTooltip"),
   hidden: true,

And then the command is automatically executed in the content process.
These DevTools bugs should probably block e10s from riding to Aurora.
harthur says these DevTools bugs are not Aurora blockers for e10s.
Whiteboard: [e10s-m7]
Summary: "tilt toggle" gcli command isn't e10s compatible → [e10s] "tilt toggle" gcli command isn't e10s compatible
I expect bug 937166 will automatically fix this, but please reopen if I'm wrong.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937166
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.