Status

P4
normal
RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: dun3buggi3, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8452288 [details]
screenie.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140703154127

Steps to reproduce:

A user could take up a single task multiple times and it gets updated on the profile and adds to the total number of tasks taken


Actual results:

The user profile gets updated eventhough the task has already been taken one.


Expected results:

There should be some sort of indication that the task has already been completed and should not be updated if the person takes up the task multiple times.
Users are able to take and re-do repeatable tasks an infinite number of times. Currently we are on the honor system not do this. In the future we can consider how to approach users who repeat a previously completed task.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Task Duplication on One and Done v2.0 → Able to repeat tasks multiple times
Target Milestone: --- → Future
Duplicate of this bug: 1036865
Priority: -- → P4
I want to count the tasks when people complete them multiple times. Basically, I want to encourage people to repeat tasks that are repeatable. If they aren't meant to be repeated, we can make them one-time tasks.
The problem is that making a task a one-time task means that only one user can ever complete it. I think the idea here was that there are some tasks that any number of users can complete, but that it would only make sense for each user to complete it once (e.g., create a Bugzilla account). I suppose that is a different requirement and maybe this bug should be updated to reflect that, if that's what we really want.
This bug is now about creating a new attribute for tasks called "One time per user". If a task is given this attribute (which should appear as a checkbox on the Task Create/Edit form), then each user would only be able to take the task once. After a user has completed the task the "Get Started" button for the task would change to "Completed" and we would also need logic to ensure that a user cannot mark the task as completed again via modifying and posting a form.
Summary: Able to repeat tasks multiple times → One time per user tasks

Comment 6

4 years ago
assigned:tessyjoseph1992@gmail.com
This is available for contributors to work on.
Target Milestone: Future → ---
Version: Version 2 → unspecified
Project is being retired.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

2 months ago
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.