Closed Bug 103588 Opened 23 years ago Closed 23 years ago

better default tooltip for linktoolbar items

Categories

(SeaMonkey :: UI Design, enhancement, P5)

All
Other
enhancement

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 102972
Future

People

(Reporter: tim, Assigned: choess)

Details

The items in the link toolbar should have better default tooltip text when the
TITLE attribute isn't specified on the LINK.  Currently, the URL is used for the
tooltip.  I propose each button get a more helpful default tooltip, such as:

Top: "Site homepage or topmost page"
Up: "One level up from this page"
Next: "Next in this series of pages"

But with better wording than what I've come up with :)

Furthermore, tooltips should be displayed when the item is disabled.  Assuming
tooltips like I proposed above, the disabled tooltip may need differnet wording.
 For example:

Next: "Next in a series of pages"
Blocks: 103053
Can we specify multiple types of tooltips conditionally in XUL?  (I think this
is feasible once we XBLize, though.)  cc'ing mpt for UI input.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P5
Target Milestone: --- → Future
What I described is possible with JavaScript.  We're already doing "conditional"
tooltips: no tooltip when disabled, URL as default, or TITLE if specified.
Sounds good.  We'll probably need the spec to write them properly, though.  I'm
working on it as fast as I can...
Assignee: blakeross → choess
Status: ASSIGNED → NEW
No longer blocks: 103053
QA Contact: sairuh → claudius
Blocks: 103053

*** This bug has been marked as a duplicate of 102972 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
VERIFIED Dupe
Status: RESOLVED → VERIFIED
No longer blocks: 103053
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.