window.open() fails before page loads

RESOLVED DUPLICATE of bug 101190

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 101190
17 years ago
17 years ago

People

(Reporter: Danek Duvall, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4+) Gecko/20011007
BuildID:    20011007

My home page is a 150kB html file distilled from my bookmarks.  At the top of
the page, I have a link which points to a javascript function that opens a
handful of windows (the ones that I want to start my day off with), followed by
a window.close() (I'll attach this link).

Because of the size of the page, it takes a while to load.  If I click on this
link before the loading is complete, the window simply closes, not opening any
of the windows I wanted.  If I remove the window.close(), then I see the
javascript code in the location bar, and the main window simply has "null" in it.

Oddly, if I then view the source of that resultant page, I not only get the
source, but also the window in the window.open() call.

Am I simply abusing javascript here, or is this a real problem?

Reproducible: Always
Steps to Reproduce:
1. Put attached link at top of large html page.
2. Load page.
3. Before page finishes loading, click on the link.
(Reporter)

Comment 1

17 years ago
Created attachment 52468 [details] [diff] [review]
text of link

Comment 2

17 years ago
Browser, not engine --> DOM Level 0
Assignee: rogerl → jst
Status: UNCONFIRMED → NEW
Component: Javascript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → desale

Comment 3

17 years ago
Danek, are you the hidden dom.disable_open_during_load pref to block pop-up 
ads?  If you are, this is a dup of bug 101190.
(Reporter)

Comment 4

17 years ago
Yes, I do have that preference enabled; it probably is a dup.

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 101190 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.