Decide what to do with "external link" field in event creation form

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: matt, Assigned: gvn)

Tracking

Details

(Whiteboard: [events] [aug8])

Attachments

(1 attachment)

It doesn't display the value anywhere on the page, and is therefore confusing to users / a bug
(Reporter)

Updated

4 years ago
Assignee: nobody → gavin
Whiteboard: [events] [july11]
Hmm - this might be hasty.  I'd worry that it might encourage users to not enter events.  I'm wondering if instead we should work to communicate the purpose of the field.
(Assignee)

Comment 2

4 years ago
Users can still add external links in the event description. Since we're no longer trying to augment existing platforms I think it makes sense to deprecate the external link field.

If we do keep it, we should change the copy at a minimum so that we're not endorsing making a separate "registration page". We should encourage people to stay within our system if possible...

Brett, can you make a call on this?
Flags: needinfo?(brett)
I agree with Gavin we should be guiding users to stay within our system, especially since that field was originally put in a as a hack because we could not integrate with other APIs. Now that we have our own RSVP, it is not serving its original purpose. HOWEVER, I think it might be better to keep the field and just change the copy because:

A) There any scenarios where someone might still want to link out to an external link, regardless of RSVP functionality, for example a website that has more information about their event or campaign. e.g, Ladies Learning Code enters a weekend event but wants to include a link to ladieslearningcode.org which has more information about the organization.

and

B) What happens to old events that had urls entered?
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1035847
(Reporter)

Comment 5

4 years ago
* Should we agree to do nothing for the time being, and punt to [july25] so we can discuss further / not do anything hasty?
yes.
Flags: needinfo?(brett)
Whiteboard: [events] [july11] → [events] [july25]
I was about to file a bug...have to note that Cassie's point about users wanting to include an external URL is right on the money. In particular *Online* Maker Parties (which we're encouraging via training and several internal Moz groups) need a URL field so that people know where on the web to participate.
(Reporter)

Comment 8

4 years ago
* Makes sense. They can also include links in their event description as well. So will need to think about the best way to support this.
(Reporter)

Comment 9

4 years ago
* Ok so... let's discuss this one. What are our options here?

a) just remove the field. so users don't have the expectation it will show up somewhere, then are confused about why it doesn't.

b) display it. Display the external URL field on the page. Sounds like users want this. 

c) something else.


Thoughts?
Flags: needinfo?(gavin)
Flags: needinfo?(brett)
(Assignee)

Comment 10

4 years ago
I think B along with a copy change that doesn't encourage using external events platforms.
Flags: needinfo?(gavin)
(Reporter)

Updated

4 years ago
Summary: Remove "external link" field from event creation form → Decide what to do with "external link" field in event creation form
(Reporter)

Comment 11

4 years ago
* Brett: what do you think?
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1029027
(Reporter)

Comment 13

4 years ago
* Moving to next train
* Let's push ahead with ( b ) -- unless Brett objects

* Gavin: are you blocked on any copy or UI to implement ( b )?
Flags: needinfo?(gavin)
Whiteboard: [events] [july25] → [events] [aug8]
(Assignee)

Comment 14

4 years ago
No, I can do B.
Flags: needinfo?(gavin)
DO B
Flags: needinfo?(brett)
Attachment #8464215 - Flags: review?(aki) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.