Assertion creating GMP plugin: NS_IsMainThread from the PGMPParent constructor

RESOLVED DUPLICATE of bug 1035653

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1035653
4 years ago
4 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Toplevel IPDL actors must apparently now be created on the main thread, because we maintain an unlocked linked list of them (somehow related to NUWA, but I'm not sure exactly how it all fits together).

The GMP plugin system currently doesn't honor this invariant and asserts in debug builds from here:

http://hg.mozilla.org/mozilla-central/annotate/8bfe3372f848/content/media/gmp/GMPService.cpp#l477
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035653
You need to log in before you can comment on or make changes to this bug.