Intermittent mochitest "FATAL ERROR: Non-local network connections are disabled and a connection attempt to snippets.mozilla.com (63.245.217.48) was made." during test_bug_461710_perwindowpb.html [@ nsSocketTransport::InitiateSocket()]

RESOLVED DUPLICATE of bug 1048375

Status

Testing
General
RESOLVED DUPLICATE of bug 1048375
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
So I guess we need to fix bug 1022785 harder?

https://tbpl.mozilla.org/php/getParsedLog.php?id=43353482&tree=Mozilla-Inbound

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-other on 2014-07-08 09:35:30 PDT for push 53a30a12d70e
slave: t-snow-r4-0086

09:43:31     INFO -  3706 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/test_bug_461710_perwindowpb.html
09:43:32     INFO -  Non-local network connections are disabled and a connection attempt to snippets.mozilla.com (63.245.217.48) was made.  You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
09:43:32     INFO -  TEST-INFO | Main app process: killed by SIGHUP
Comment hidden (Treeherder Robot)
That bug (and the comment in the prefs file) specifically call out "android snippets":
http://hg.mozilla.org/mozilla-central/annotate/2d88803a0b9c/testing/profiles/prefs_general.js#l171

This URL comes from the browser.aboutHomeSnippets.updateUrl pref:
http://hg.mozilla.org/mozilla-central/annotate/2d88803a0b9c/browser/app/profile/firefox.js#l289

I don't know if stubbing that out to localhost will break any tests, but it ought to be easy enough to test.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Summary: Intermittent test_bug_461710_perwindowpb.html | application crashed [@ nsSocketTransport::InitiateSocket()] after "Non-local network connections are disabled and a connection attempt to snippets.mozilla.com (63.245.217.48) was made." → Intermittent mochitest "FATAL ERROR: Non-local network connections are disabled and a connection attempt to snippets.mozilla.com (63.245.217.48) was made." during test_bug_461710_perwindowpb.html [@ nsSocketTransport::InitiateSocket()]

Comment 6

4 years ago
Margaret, it looks like something on desktop isn't honouring:

http://mxr.mozilla.org/mozilla-central/source/testing/profiles/prefs_general.js#186
187 user_pref("browser.snippets.enabled", false);
188 user_pref("browser.snippets.syncPromo.enabled", false);

And is attempting connections to snippets.mozilla.com, which is gotten via:
http://mxr.mozilla.org/mozilla-central/source/browser/modules/AboutHome.jsm#74

I don't suppose you could take a look? :-)
Blocks: 965358
Flags: needinfo?(margaret.leibovic)

Comment 7

4 years ago
06:07:05     INFO -  3996 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/osfile/tests/mochi/test_osfile_front.xul | took 216ms
06:07:05     INFO -  3997 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/perf/test_pm.xul
06:07:06     INFO -  3998 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/perf/test_pm.xul | took 41ms
06:07:06     INFO -  3999 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_303567.xul
06:07:06     INFO -  4000 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_303567.xul | took 149ms
06:07:06     INFO -  4001 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_341972a.xul
06:07:06     INFO -  4002 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_341972a.xul | took 80ms
06:07:06     INFO -  4003 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_341972b.xul
06:07:06     INFO -  4004 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_341972b.xul | took 104ms
06:07:06     INFO -  4005 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_342484.xul
06:07:06     INFO -  4006 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_342484.xul | took 109ms
06:07:06     INFO -  4007 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_371798.xul
06:07:06     INFO -  4008 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_371798.xul | took 273ms
06:07:06     INFO -  4009 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_381357.xul
06:07:07     INFO -  4010 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_381357.xul | took 63ms
06:07:07     INFO -  4011 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_favicon_annotations.xul
06:07:07     INFO -  4012 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_favicon_annotations.xul | took 54ms
06:07:07     INFO -  4013 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_history_post.xul
06:07:07     INFO -  4014 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_history_post.xul | took 64ms
06:07:07     INFO -  4015 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_reloadLivemarks.xul
06:07:09     INFO -  4016 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/chrome/test_reloadLivemarks.xul | took 2085ms
06:07:09     INFO -  4017 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/test_bug_411966.html
06:07:09     INFO -  4018 INFO TEST-OK | chrome://mochitests/content/chrome/toolkit/components/places/tests/test_bug_411966.html | took 190ms
06:07:09     INFO -  4019 INFO TEST-START | chrome://mochitests/content/chrome/toolkit/components/places/tests/test_bug_461710_perwindowpb.html
06:07:10     INFO -  4020 INFO Non-local network connections are disabled and a connection attempt to snippets.mozilla.com (63.245.217.48) was made.  You should only access hostnames available via the test networking proxy (if running mochitests) or from a test-specific httpd.js server (if running xpcshell tests). Browser services should be disabled or redirected to a local server.
Blocks: 1022785

Comment 8

4 years ago
(In reply to Ed Morley [:edmorley] from comment #6)
> Margaret, it looks like something on desktop isn't honouring:
> 
> http://mxr.mozilla.org/mozilla-central/source/testing/profiles/prefs_general.
> js#186
> 187 user_pref("browser.snippets.enabled", false);
> 188 user_pref("browser.snippets.syncPromo.enabled", false);
> 
> And is attempting connections to snippets.mozilla.com, which is gotten via:
> http://mxr.mozilla.org/mozilla-central/source/browser/modules/AboutHome.
> jsm#74
> 
> I don't suppose you could take a look? :-)

Those are both mobile-specific prefs, so it makes sense that desktop isn't honoring them :)

I'm redirecting this needinfo to mak, since it looks like he's the one who's worked on this on desktop.
Flags: needinfo?(margaret.leibovic) → needinfo?(mak77)
Forwarding to Drew for investigation, cause I don't think I have enough time to look into this atm :(

Btw, it's strange, we set a nonexisting snippets url in /testing/profiles/prefs_general.js
http://mxr.mozilla.org/mozilla-central/source/testing/profiles/prefs_general.js#230

Note that this only happened on 5 Aug: http://hg.mozilla.org/mozilla-central/rev/5d3084f4f861

All of the failures here seem to predate that.
Flags: needinfo?(mak77) → needinfo?(adw)
(In reply to Marco Bonardo [:mak] (Away 15-31 Aug) from comment #9)
> All of the failures here seem to predate that.

ehr, apart comment 7

Comment 11

4 years ago
Marco sounds right to me, the snippets URL was changed for tests.  The only places where snippets.mozilla.com is mentioned in the entire tree are the browser and mobile pref files, and the browser one is overridden in mochitests by the revision Marco linked to.  http://mxr.mozilla.org/mozilla-central/search?string=snippets.mozilla

Ed, it's not clear where your comment 7 is from.  I'm guessing it's from before Aug 5 or from some tree that didn't have the test change applied.  If that's true, I think we can close this bug for now.
Flags: needinfo?(adw)
This hasn't happened since 5th Aug, so yeah believe bug 1048375 fixed it. Thank you :-)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048375
You need to log in before you can comment on or make changes to this bug.