[B2G][2.0][l10n][Contacts] Polish: "Facebook Friends" header displays truncated when linking a specific contact

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jdegeus, Assigned: stef, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected)

Details

(Whiteboard: LocRun2.0)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8452668 [details]
Facebook_header.png

[B2G][2.0][l10n][Contacts] Polish: "Facebook Friends" header displays truncated when linking a specific contact

Description:
When users are in Polish language and attempt to link a specific contact to a Facebook Friend, the user will see the header displays truncated

Setup:
Settings > Language> pl - Polish
Have a Facebook account with atleast one friend. 

Repro Steps:
1) Update a Flame device to BuildID: 20140702000201
2) Select Contacts> Select a contact(user may need to add a contact)
3) Sign into Facebook account
4) Observe header displays truncated

Actual:
"Facebook Friends" header displays truncated when linking a contact
Expected:
"Facebook Friends" displays truncated

Environmental Variables:
Device: Flame 2.0
BuildID: 20140707000200
Gaia: ef67af27dff3130d41a9139d6ae7ed640c34d922
Gecko: f53099796238
Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.

Repro frequency: 3/3
Link to failed test case: https://moztrap.mozilla.org/manage/case/12798/ - This fails Step 7.
See attached: Screenshots - Facebook_header.png
(Reporter)

Comment 1

4 years ago
This issue not occur on Flame 1.4. 

Environmental Variables:
Device: Flame 1.4
Build ID: 20140702063007
Gaia: e8599c2b346addf3bf857310502e5b542ae7d0b2
Gecko: 5ff8eb391b65
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: fixed → unaffected
Flags: needinfo?(ktucker)
Please provide the actual result for the Flame 1.4
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(jdegeus)
(Reporter)

Comment 3

4 years ago
Flame 1.4 Actual Result: "Facebook Friends" displays closer to the left side of the header and does not display truncated
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(jdegeus) → needinfo?(ktucker)
This is a regression from 1.4 but seems minor.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Comment 5

4 years ago
I do not exactly understand repro steps (3) but how this is different in general form bug 1036086 - what is the difference between facebook-serviceName and fbFriends entities?

Also, why we are not using all that available space?
Assignee: marcoos+bmo → splewako
Flags: needinfo?(epang)
This is basically bug 1036191, so I'd suggest to focus the discussion in that bug for now and see if it fixes this one as well.

I think the blank area on the right is due to an hidden button, which is visible when you hit the dialog from Contacts->Settings.
https://bug1036191.bugzilla.mozilla.org/attachment.cgi?id=8452786
Flags: needinfo?(epang)
(Assignee)

Updated

4 years ago
Depends on: 1036191

Comment 7

4 years ago
It looks untruncated on my Keon (latest nightly). Could you please reverify?
(Assignee)

Updated

4 years ago
Flags: needinfo?(jdegeus)
(Assignee)

Comment 8

3 years ago
Assuming it is fixed, please reopen if it is not.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.