Closed Bug 10361 Opened 21 years ago Closed 20 years ago

RFE: Display configuration name on each wizard screen and at top of Show Summary info

Categories

(CCK Graveyard :: CCK-Wizard, defect, P2)

x86
Windows 95
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: robinf, Assigned: vparthas)

References

Details

We'd like to be able to display the CCK configuration name on each wizard
screen. However, given the limited space that's left on these screens, this may
not be possible. The most logical place for the configuration name to appear is
immediately underneath the banner on each screen.

Alternatively, and to save precious space on the screens, is it possible to
display the config name in the title bar area? This would be preferable, since
the name would be more visible there. Displaying the name right-justified in the
title bar is my suggestion if we can do this.

We'd also like to display the configuration name at the top of the Show Summary
window that appears when you click Show Summary on the last page of the wizard.
Assignee: selmer → gayatrib
Target Milestone: M13
Gayatri, putting this in the title is a good idea, is that easy to add?  There
should probably be a second bug for the show summary change...
The title bar is the best place to put it.  Basically, we could put the config
file inside parens.  For example, here are some examples:

Option 1: Netscape Client Customization Kit (myisp.cfg)
Option 2: Netscape Client Customization Kit (Current Configuration: MYISP)

We can finalize the actual text later.  Great idea!
Priority: P3 → P2
Elevating to P2 since this affects the doc.
Status: NEW → ASSIGNED
*** Bug 14537 has been marked as a duplicate of this bug. ***
*** Bug 14162 has been marked as a duplicate of this bug. ***
*** Bug 15331 has been marked as a duplicate of this bug. ***
Assignee: gayatrib → varada
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed- have to make neccessary changes in the ini files in the title to get the
config name reflected in the title.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
reopening

The Configuration Name does appear in the title bar.  However, it needs to be
right justified if possible.
Status: REOPENED → ASSIGNED
It is standard windows practice to not have the topic be split into two parts -
one being left and the other right justified and is also a bit difficult to
implement - Hence I would like to know from bijal and robin which format they
would like
<foo-config> - Netscape Client Customization Kit 1.0
or
Netscape Client Customization Kit 1.0 - <foo-config>
I am okay with both.  On Communicator 4.7, Navigator as well as Mail give the
page title and then the "-Netscape" brand.  Maybe we follow these Netscape
standards:

<config> - Netscape Client Customization Kit 5.0
Fine with me.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
The new format will be <config> - Netscape Client Customization Kit - and the
neccessary changes have been made in the inifiles and the wizard to reflect the
new format.
Status: RESOLVED → VERIFIED
marking this Verified Fixed.
You need to log in before you can comment on or make changes to this bug.