After a user signs in with GitHub for the first time, prompt them to optionally associate a Persona account

RESOLVED DUPLICATE of bug 1049982

Status

developer.mozilla.org
Sign-in
--
enhancement
RESOLVED DUPLICATE of bug 1049982
4 years ago
4 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
For more information about this feature, see the following:

Page 4, Point E of http://cl.ly/1y3L3e332P19
(Reporter)

Comment 1

4 years ago
The PDF shows the user on the profile edit page after being logged in with GitHub for the first time. MDN does not currently direct the user to the profile edit page after logging in for the first time. Would we like to do that, or could this prompt appear anywhere?

It looks like the former is preferred, but I just wanted to double-check.
Flags: needinfo?(hhabstritt.bugzilla)

Updated

4 years ago
Severity: normal → enhancement
We can defer ability to dismiss the notification message (we should file a new bug for adding it later).
We just discussed the workflow needed for prompting the user to connect their Persona account. The prompt needs to happen *before* we allow the user to enter new profile information. 

The wireframe attached to this bug has an inline notification, which is now incorrect. A modal notification style is needed so that the user first addresses connecting the Persona account before continuing to enter new profile information. 

Flow:
1. User signs in with Github for first time
2a. If verified email match, Persona and Github accounts automatically connected
2b. If no verified email match, when user lands on their new Edit Profile page, modal notification is seen over page. Choice in modal notification must be made before continuing to Edit Profile page. 

Todo:
Stephanie to create modal notification style
Flags: needinfo?(hhabstritt.bugzilla)
(In reply to John Karahalis [:openjck] from comment #1)
> The PDF shows the user on the profile edit page after being logged in with
> GitHub for the first time. MDN does not currently direct the user to the
> profile edit page after logging in for the first time. Would we like to do
> that, or could this prompt appear anywhere?
> 
> It looks like the former is preferred, but I just wanted to double-check.

Hi John, 
After signing in with Github and a verified email is NOT detected as a match with an MDN account, we should (as indicated in the flow in the PDF) bring the user to the edit profile page to create their new profile. This also acts as confirmation that the new account was created. See also: comment 3 that describes modal that is needed over edit/new profile page. 

For users whose verified email is a match with an existing MDN Persona account, we will bring them back to whatever page they were on when they clicked "Sign in with Github".
No longer blocks: 1025348
Blocks: 1017085
Component: User profiles → Login
Duplicate of this bug: 1049974
Created attachment 8470248 [details]
"The username is already taken"

I'm not sure what is meant by "verified email" in Holly's #4 comment above but I got hit by this too. 

I supposed I've signed in with Persona at some point in the past. I can't remember. 
And that's the problem. I don't want to have 2 accounts. I want one account: "peterbe" with two different ways to sign in. 
The problem is that I can't remember which auth service I use(d). This is true for Stackoverflow.com too https://www.dropbox.com/s/07pkec5z0waovmv/Screenshot%202014-08-08%2013.33.37.png

Now, it's really plausible that the username is taken because some other jerk got there before me who also likes to use that username. Either way, it should pop up and say "If you think that's you but you used a different way to authenticate, to proceed click here to send a verification email to mai***@pet***"
Created attachment 8471250 [details]
Screen Shot 2014-08-11 at 17.35.52.png

It looks like used to have a form for users who have forgotten which email they signed up with. (https://bugzilla.mozilla.org/show_bug.cgi?id=922880). I think we need to re-create it in the new allauth world order.

I suggested we change the error message to "This username is already taken. Please choose another or _recover your account_." With a link to the form.

Going to needsinfo because this is scope creep and needs to be prioritized.
Flags: needinfo?(mars)
:jezdez and I talked about this and he thinks the recover account functionality will have to wait. There are privacy/security concerns we need to think through because this gets really complicated once we have a 3rd service.

I filed bug #1052849 for that.

In the interim we will have to ask people to file bugs if they are having trouble logging in. I will contact the bugzilla folks to see if we can create a custom bug report form to simplify this.
Flags: needinfo?(mars)
This turned out to be very related to bug #1049982 so in discussion with :shobson I'm combining them to not have two places for discussions.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049982
Blocks: 1050406
No longer blocks: 1050406
You need to log in before you can comment on or make changes to this bug.