Video playback on Vimeo.com broken in latest Nightly when layers.offmainthreadcomposition.enabled=true

RESOLVED DUPLICATE of bug 1035101

Status

()

Core
Audio/Video
--
major
RESOLVED DUPLICATE of bug 1035101
3 years ago
3 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Video playback on Vimeo.com is broken in the latest Nightly build (Built from https://hg.mozilla.org/mozilla-central/rev/c45f6e6d6005). You can hear the audio, but the video portion is just black. Tried with a clean profile, same behavior. Verified to not be a Vimeo issue as the videos playback on IE and Chrome. I could not see any errors in the browser console. Unable to replicate the issue on other sites like YouTube or DailyMotion.
(Reporter)

Updated

3 years ago
Keywords: regression

Comment 1

3 years ago
Problem is caused when pref 'layers.offmainthreadcomposition.enabled = true'.  False results in the video playing.
(Reporter)

Comment 2

3 years ago
I was able to test this issue in the 7/5 Nightly build and the video played fine. I haven't tested 7/6 or 7/7 yet to see where the regression might be hiding.
(Reporter)

Updated

3 years ago
Summary: Video playback on Vimeo.com broken in latest Nightly → Video playback on Vimeo.com broken in latest Nightly when layers.offmainthreadcomposition.enabled=true

Comment 3

3 years ago
setting pref media.windows-media-foundation.enabled = false also fixes the problem with OMTC enabled.

Comment 4

3 years ago
Might be a dup of https://bugzilla.mozilla.org/show_bug.cgi?id=1035101
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035101
You need to log in before you can comment on or make changes to this bug.