[dev] Unable to add a review because rating stars selection is unavailable

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Assigned: mstriemer)

Tracking

({regression})

x86_64
Linux
regression
Points:
---

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8452935 [details]
screenshot.png

This is only happening on dev. When trying to add a review, I can't select a rating star. That makes it impossible to add a review.

#STR:
1. Login on: https://marketplace-dev.allizom.org
2. Search for an app (E.g: Wikipedia)
3. While you are on the details page of the app, tap 'Write a review' button
4. Write a review in the text box and rate the app by selecting a rating star

#Expected results
Ratings stars selection is available, my review is added after I tap Submit button

#Actual results
Ratings stars selection is unavailable => I'm unable to add a review
This issue is reproduced manually on certain environments:
Windows 7 x86 
Ubuntu 13.10 x64
Mobile gaia 1.3

It works fine on Windows 7 x64

Note: On the environments that it does not work I managed to select a rating with javascript commands, but not manually.

Updated

4 years ago
Whiteboard: [fromAutomation]
Keywords: regression
Summary: [dev] Unable to add a review because rating starts selection is unavailable → [dev] Unable to add a review because rating stars selection is unavailable
Priority: -- → P1
Likely caused by https://github.com/mozilla/fireplace/commit/2cac0ec9

Are you sure this doesn't happen on production? Because that commit was in yesterday's push's tag.
(Assignee)

Updated

4 years ago
Assignee: nobody → mstriemer
(Assignee)

Comment 4

4 years ago
I ran a git-bisect and it showed https://github.com/mozilla/fireplace/commit/5000ae080e45e480bf9677572dc2cea8d63801d5 as the first bad commit.
(Assignee)

Comment 5

4 years ago
This is working -dev now that the bad commit has been reverted.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.