An easier way to correct character coding (encoding) in emails.

NEW
Unassigned

Status

MailNews Core
Internationalization
--
enhancement
17 years ago
5 years ago

People

(Reporter: 石庭豐 (Seak, Teng-Fong), Unassigned)

Tracking

(Blocks: 1 bug, {intl})

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010925
BuildID:    20010925

     With more and more people sending Web-based emails, more and more emails'
charset are badly used/declared.  All those emails' charset is "ISO-8859-1" but
actually in my case half of them are not; they should be "Big5".  I have the
habit of keeping important emails.  So, in order to save my effort from manually
choosing the correct encoding from the menu every time I want to read the emails
again, I would do the following:

move the email to an empty folder;
quit Mozilla;
use a text editor to correct the "charset" of the email header;
remove the_folder_file.msf (otherwise it won't show up correctly in Mozilla);
finally reopen Mozilla

     So, as you can see, if I receive one mail of this type everyday, that
becomes a very very tedious work.  So, my wish is to have an easier way to
correct character coding in email.

     Maybe there aren't many people in need of such functionality, so I don't
mind if the menu item isn't very obvious. It only needs to exist and I'm already
satisfied.

PS: I know there's the "Edit > Edit Message as New", but there's a problem: it
changes the sender to me!!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
QA Contact: esther → andreasb

Updated

17 years ago
Keywords: intl
QA Contact: andreasb → ji

Comment 1

17 years ago
There is a way to set a character set using "folder property" dialog. Please try
that.
(Reporter)

Comment 2

17 years ago
Yes, this can be a temporary solution. But I'd still like my suggestion to be
implemented. The reason is that there're several encodings in one language. Eg,
ISO-8859-1, ISO-8859-15, Windows-I-dont-know-what and UTF-8 for French, Big-5,
HZ, GB2312 and UTF-8 for Chinese. Until everybody uses Unicode, we still have to
face this problem :(

Updated

17 years ago
Target Milestone: --- → Future

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 3

17 years ago
As far as I can see, I  see 2 types of solutions to this problem:

1. If you have several encodings in your language, then create
   folders for each of them: 1) HZ, 2)GB2312,3)Big5, etc.
   Use folder properties dialog to "force" the default encoding to all msgs.
   You filter your email msgs to appropriate mailboxes and view them
   with no need to engage the menu at all.
** This solution is available right now. **

2. Locking the override easily. This will be a new feature. When you override
   a wrong charset, the user will have 2 choices, 1) a simple override -- 
   which lets you override one msg only, 2) continuous override -- this 
   override option lets you continue the override, i.e. locking the
   override option until you unlock it. We might want to implement the
   override ON & OFF via a keyboard shortcut. 

I would like to suggest we try alternative #1. I think that workaround is 
OK for many situations. 
(Reporter)

Comment 4

17 years ago
Katsuhiko, thanks to your suggestions, but in my case they are less practical
than I modified the source code.  As I've explained, there're several encodings
available for each language, but I seldomly receive such "wrongly encoded"
emails (mostly come from Hotmail and other web-based emails).  On the other
hand, from the same person, it's possible that I receive emails in several
languages (French and Chinese, eg).  So, if I create several mail folder of
different encodings for each person, it's impossible to get out of such
difficult situation.  That's why, as I explained, I'd prefer launch NotePad and
change the source code, once and for all!

Comment 5

17 years ago
> That's why, as I explained, I'd prefer launch NotePad and
> change the source code, once and for all!

If you receive such a message only rearely, then why is it not
practical for you to use the Character Coding menu to correct such 
a problem?

View | Character Coding | More | East Asian | Chinese Traditional (Big5)

By choosing this menu item, you can override the incorrect message's
encoding for that message only. This is essentially the same thing
as you editing the Content-Type charset header. It takes less time
also.

(Reporter)

Comment 6

16 years ago
It turns out that such emails are not so seldom.  I found that Netscape 4.x
English version installed within Win Chinese version can display Chinese, but
when the message is sent, the encoding is still ISO-8859-1.

On the other hand, I've got the habit to store old messages in personal folders.
 So it's very annoying to go through
View | Character Coding | More | East Asian | Chinese Traditional (Big5)
whenever I re-read an old message.  So I'd prefer "correct" its header once and
for all.

I understand that Mozilla 1.0 is about to release and people aren't free to
think about this bug/suggestion.  What a pity!  So, I'll close it myself, though
reluctantly :-(
(Reporter)

Comment 7

16 years ago
It's clear to me that nobody's going to implement this, so it's marked
WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 8

15 years ago
More than 2 years have passed since this wish has been first made.
I'm ever getting more and more and more emails without the proper charset :(
Could anyone reconsider this wish?  Maybe we could do it in a different manner?

I see the following feature in OE6:
after you've opened a mail and noticed that its encoding might be wrong, you
click on the menu to use a correct one.  This choice is somewhat memorised by OE
because when you click to read another message and click back to this one, the
message won't display wrong because OE uses the encoding you've chosen beforehand.

In Outlook 2k, XP and 2k3, once you've chosen an encoding and close the message
window, you're even asked if you would like to save the change permanently. 
This is quite nice.
Product: MailNews → Core

Comment 9

10 years ago
(In reply to comment #8)
> This choice is somewhat memorised by OE
> because when you click to read another message and click back to this one, the
> message won't display wrong because OE uses the encoding you've chosen 
> beforehand.

This seems to be what bug 208917 requests, duplicate?
(Reporter)

Comment 10

10 years ago
Yes, bug 208917 is a duplicate.  I'm going to reopen this bug again.
This bug didn't get the appropriate attention maybe because the component was set to MIME.  I'm going to set it to i18n as well.
Status: RESOLVED → REOPENED
Component: MailNews: MIME → MailNews: Internationalization
Resolution: WONTFIX → ---
(Reporter)

Updated

10 years ago
Blocks: 208917
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
QA Contact: ji → i18n

Updated

5 years ago
Assignee: bugzilla → nobody
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.