Closed Bug 1036355 Opened 5 years ago Closed 4 years ago

[Collection App] Collections are not updated after installing bookmarks from browser

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect, P3)

All
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: crdlc, Unassigned)

References

Details

(Whiteboard: [systemsfe])

STR:

1) Go to homescreen
2) Open http://www.facebook.com
3) Click on the star icon
3) Add this bookmark to homescreen

Expected:

Social collection has this new bookmark in its list of pinned icons

Result:

No bookmark in social smart collection

-----

E/GeckoConsole( 7352): [JavaScript Error: "TypeError: GaiaGrid.Bookmark is not a constructor" {file: "app://collection.gaiamobile.org/js/home_icons.js" line: 63}]

After fixing this dependency I can see how ev.me makes the query but the response is an empty object
Hi Amir, if there is a problem in the server, after fixing it there, I could fix the dependency in Gaia. Thanks a lot
Flags: needinfo?(amirn)
Whiteboard: [systemsfe]
Flags: needinfo?(amirn)
QA Wanted - Was this working in the old e.me search in 1.4?
Blocks: 1015336
No longer blocks: vertical-homescreen
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Keywords: qawanted
This bug repro's on: Flame 2.1 Master, Flame 2.0, Flame 1.4 and Buri 2.1

Actual Results: Adding Facebook.com bookmark to the homescreen does NOT add it to the pinned apps in the Social Collection.

Environmental Variables:
Device: Flame Master
Build ID: 20140708201331
Gaia: 0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko: 196d05832e12
Version: 33.0a1 (Master)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Flame 2.0
Build ID: 20140708163231
Gaia: 1dd043857399c713e3b509c0ed31bdf20326f08b
Gecko: 0b5f757da75a
Version: 32.0a2 (2.0)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
Build ID: 20140708070432
Gaia: 229864ff4ad90899f017341b9e81ed0b53498c66
Gecko: 7e146a1d7542
Version: 30.0 (1.4)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Buri Master
Build ID: 20140708201331
Gaia: 0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko: 196d05832e12
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
I double checked with our server guys. The NativeInfo api does not support BookmarkURLs as guids.
Sorry for confusing you Crisitan :)
Closing because it is not supported in 1.4. My mistake was when I read this https://github.com/mozilla-b2g/gaia/blob/master/apps/collection/js/native_info.js#L48

I will fill a new bug to remove the call to 'install' for bookmarks from vertical home because it is not supported
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
See Also: → 1036823
Duplicate of this bug: 1043693
Reopening to add fixing this this to the backlog.
Status: RESOLVED → REOPENED
blocking-b2g: --- → backlog
Resolution: INVALID → ---
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage+] → [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage+][lead-review+]
Priority: -- → P3
blocking-b2g: backlog → ---
Mass update: Resolve/Wontfix all existing collections bugs as this feature is now removed.

Please re-open or file a new bug if you feel that this bug still exists in master.
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.