File&Compare Viewer broken

VERIFIED FIXED in 2014-07-15

Status

Marketplace
Reviewer Tools
P1
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: eviljeff, Assigned: dethe)

Tracking

({regression})

Avenir
2014-07-15
regression
Points:
---

Details

(Whiteboard: [qa+])

(Reporter)

Description

4 years ago
TypeError: require is not a function devreg-min.js:9

It happened after the 2014-07-08 push (I believe)

Static file viewing is missing all source code formatting and validation warning integration (its rendered with client side js);

Compare file viewing is completely broken.

e.g. https://marketplace.firefox.com/files/compare/257249...255679/
(Reporter)

Comment 1

4 years ago
actually, static file viewing is essentially completely broken too as the file tree is missing.
Priority: -- → P2
Priority: P2 → P1
Assignee: nobody → delza
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1037480
https://github.com/mozilla/zamboni/commit/867032

Sorry, Andrew, this regressed. Thanks, Dethe, for fixing this!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-07-15
Whiteboard: [qa+]

Comment 4

4 years ago
Please add some STR.
(Assignee)

Comment 5

4 years ago
Assuming "STR" means "Steps to reproduce":

* Using reviewer tools, find a packaged app
* In the App History, click on Contents

Expected: Takes you to File & Compare Viewer, shows any validation messages, allows you to load other files

Actual: Takes you to File & Compare Viewer, validation never loads (shows spinner), file loading broken, console message "require is not a function devreg-min.js:9".

Comment 6

4 years ago
Verified in FF33 (Win7)
The issue is no longer reproducible in marketplace-dev.allizom.org: http://screencast.com/t/V81sUqO9F0nm

The is is still reproducible in stage: http://screencast.com/t/fBgZvt2QO
Was this fixed pushed in stage?
Flags: needinfo?(delza)
(Assignee)

Comment 7

4 years ago
Looks like it was not pushed on Friday. Coming soon to a staging near you.
Flags: needinfo?(delza)

Comment 8

4 years ago
Works now on stage: http://screencast.com/t/JSbMycwy
Closing
Status: RESOLVED → VERIFIED

Comment 9

4 years ago
Issue still persists. Mind to reopen?
(Assignee)

Comment 10

4 years ago
[:jpj] Still persists on which server? I believe the deployment to production was delayed until next Tuesday, so it very likely remains until then, but it should be fixed on staging and -dev.

Comment 11

4 years ago
Whoops. Wasn't aware of that.
You need to log in before you can comment on or make changes to this bug.