Closed Bug 1036386 Opened 9 years ago Closed 9 years ago

When hitting network errors the SIM number is not displayed in MMI/USSD messages

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gsvelto, Assigned: gsvelto)

References

Details

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1002327 +++

Sending MMI codes when the network is offline will yield a regular USSD message display stating the error that occurred but the title will be missing the SIM number that regular USSD messages get.
This patch applies on top of attachment 8452999 [details] [diff] [review] and is fairly straightforward in that it adds the SIM number to whatever error message is produced by the MMI/USSD code. This hadn't been done as part of bug 1002327 because I hadn't fully grasped how the MMI/USSD screen was updated.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Attachment #8453064 - Flags: review?(anthony)
Comment on attachment 8453064 [details] [diff] [review]
[PATCH] Add the SIM number to MMI/USSD error messages

Review of attachment 8453064 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good but tests are missing.
Attachment #8453064 - Flags: review?(anthony) → review-
Now with unit-tests aplenty and some linter cleanups to the affected code.
Attachment #8453064 - Attachment is obsolete: true
Attachment #8454363 - Flags: review?(anthony)
Comment on attachment 8454363 [details] [diff] [review]
[PATCH v2] Add the SIM number to MMI/USSD error messages

Review of attachment 8454363 [details] [diff] [review]:
-----------------------------------------------------------------

I've left my only comment on Github, sorry.

\o/ for extra testing!
Attachment #8454363 - Flags: review?(anthony) → review+
(In reply to Anthony Ricaud (:rik) from comment #5)
> I've left my only comment on Github, sorry.

Thanks for the review, the this.* constants were coming from the old custom mock mozMobileConnection implementation and I forgot to bring them over. I'll correct that code even though they're not used yet because I still hope to revive the addtional unit-tests sooner or later. I've updated the PR and will wait for a green Try/Travis before merging.
Try was green, landed on gaia/master 728f9595af428bc2ddc0b1018909ef043aa7fa82

https://github.com/mozilla-b2g/gaia/commit/728f9595af428bc2ddc0b1018909ef043aa7fa82
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.