Closed Bug 1036434 Opened 8 years ago Closed 7 years ago

In-content preferences doesn't show the complete scrollbar

Categories

(Firefox :: Preferences, defect)

defect
Not set
normal
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 38
Iteration:
38.2 - 9 Feb

People

(Reporter: sankha, Assigned: Kwan)

References

Details

Attachments

(3 files)

Attached image screenshot
Open the in-content preferences tab, make the window a bit smaller so that the contents don't fit entirely. The scrollbar appears on the right as expected, but the end of the scrollbar is not seen entirely.

Attached is a screenshot of the same.
Flags: firefox-backlog+
Points: --- → 3
Duplicate of this bug: 1091324
Logically, setting (max-)height: 100%; on the <stack>, the <hbox>, and .main-content should work. But I've tested with the devtools, and there's some xul weirdness preventing us to do so.
This seems to be the fault of the #categories list on the left.  Set its max-height to 100vh and presto, the scroll bar on the main-content works properly.
As a bonus, "Advanced" and the other sections are now reachable in vertically-challenged windows (which I almost filed as a new bug).  Unfortunately the #categories list then gets an ugly and unnecessary horizontal scroll, but that's fixable with an "overflow-x: hidden !important;" on its scrollbox child.
Assignee: nobody → moz-ian
Status: NEW → ASSIGNED
Attachment #8554215 - Flags: feedback?(jaws)
Comment on attachment 8554215 [details] [diff] [review]
Fix display of #categories list

This seems sane enough to me, and I can't find a better way to do this. It should really exist, but I bet that the stack and XUL's amazing magic are what make this work the way it does currently... some days, I can't wait for us to move to using HTML!
Attachment #8554215 - Flags: feedback?(jaws) → review+
OS: Linux → All
Hardware: x86_64 → All
Oh, and for bonus points, please file a bug or update the patch to include removing the top margin/padding/whatever on that list for small window heights, because when the list is scrollable and the padding remains, it looks odd. :-)
(In reply to :Gijs Kruitbosch from comment #5)
> Oh, and for bonus points, please file a bug or update the patch to include
> removing the top margin/padding/whatever on that list for small window
> heights, because when the list is scrollable and the padding remains, it
> looks odd. :-)

Yeah I wasn't a fan of how that looked either.  Fortunately easy enough to fix once I thought about it (and remembered I'd done something similar on the web recently)
Attachment #8554215 - Attachment is obsolete: true
Attachment #8554942 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8554942 [details] [diff] [review]
Fix display of #categories list v2, now with less padding

Review of attachment 8554942 [details] [diff] [review]:
-----------------------------------------------------------------

Matt, now with magic numbers to fix the padding at the top... any thoughts about how to avoid that, or whether we should leave them out altogether?
Attachment #8554942 - Flags: review?(gijskruitbosch+bugs) → review?(MattN+bmo)
(In reply to :Gijs Kruitbosch from comment #7)
> Comment on attachment 8554942 [details] [diff] [review]
> Fix display of #categories list v2, now with less padding
> 
> Review of attachment 8554942 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Matt, now with magic numbers to fix the padding at the top... any thoughts
> about how to avoid that, or whether we should leave them out altogether?

The 280px in padding-top can be de-magicked with some var() usage, but the 319px in the media query is kind of stuck there without @medias supporting var(), as far as I can tell.
Comment on attachment 8554942 [details] [diff] [review]
Fix display of #categories list v2, now with less padding

Actually, you want to know why this way is a bad idea?
The new search pane.  I wrote that patch against release via Stylish (and an en-GB one at that), and it doesn't work properly on en-US nightly because of the extra category.

I'll do it as a follow up in a separate bug then, since it'll involve some JS (and more repetitive CSS than I'd like without Bug 968761, and @media queries taking calc(), or at least var())
Attachment #8554942 - Flags: review?(MattN+bmo) → review-
Attachment #8554215 - Attachment is obsolete: false
Thanks!

remote:   https://hg.mozilla.org/integration/fx-team/rev/25da9ba50d8d
Flags: qe-verify-
Flags: in-testsuite-
Blocks: 1126278
https://hg.mozilla.org/mozilla-central/rev/25da9ba50d8d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
Iteration: --- → 38.2 - 9 Feb
You need to log in before you can comment on or make changes to this bug.