Closed Bug 1036525 Opened 6 years ago Closed 6 years ago

elfhack failing to build with missing DSO_SONAME

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla33

People

(Reporter: sfink, Assigned: sfink)

References

Details

Attachments

(1 file)

Tail end of build log:

 2:06.88 pkgdata: ar r ../lib/libicudata.a ./out/tmp/icudt52l_dat.o
 2:06.88 pkgdata: ranlib ../lib/libicudata.a
 2:06.89 Note: rebuild with "/usr/bin/gmake VERBOSE=1 all-local" to show all compiler parameters.
 2:08.84 elfhack
 2:08.91 //usrusr//binbin//ldld::  fatalfatal  errorerror: :- h-:h :must  musttake  takea  anon -nonempty- emptyargument
 2:08.91 argument
 2:08.91 collect2: error: ld returned 1 exit status
 2:08.91 collect2: error: ld returned 1 exit status
 2:08.91 distcc[6357] ERROR: compile (null) on localhost failed
 2:08.91 distcc[6358] ERROR: compile (null) on localhost failed
 2:08.92 gmake[5]: *** [test-array.so] Error 1
 2:08.92 gmake[5]: *** Waiting for unfinished jobs....
 2:08.92 gmake[5]: *** [test-ctors.so] Error 1
 2:08.92 gmake[4]: *** [build/unix/elfhack/libs] Error 2
 2:08.92 gmake[3]: *** [libs] Error 2
 2:08.92 gmake[2]: *** [default] Error 2
 2:08.92 gmake[1]: *** [realbuild] Error 2
 2:08.92 gmake: *** [build] Error 2
 2:08.95 347 compiler warnings present.

The problem is that c++ is getting invoked with |-Wl,-h,| which looks like it means that DSO_SONAME is missing. It's clear to me why -- the Makefile sources autoconf.mk, which defines MKSHLIB in terms of $(DSO_SONAME), but nothing sets that. I don't know how it's supposed to work. (rules.mk might set it properly, but it sees that MKSHLIB has already been set.)

If I --disable-elf-hack, the build works. So it's not that everything is messed up.

This is a clobber build. I haven't tried a fresh clone build.
Assignee: nobody → sphink
Status: NEW → ASSIGNED
Attachment #8453454 - Flags: review?(mh+mozilla) → review+
Duplicate of this bug: 1036747
https://hg.mozilla.org/mozilla-central/rev/cc43e1354c9d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.