drag text of different paragraph style doesn't inherit drop paragraph style

VERIFIED INVALID

Status

SeaMonkey
Composer
VERIFIED INVALID
17 years ago
13 years ago

People

(Reporter: TucsonTester2, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.9

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE+)

(Reporter)

Description

17 years ago
Build ID: 20011004

If you have a line of text in heading 1 that you want to drag into text that has
a body text paragraph style, then the drag and drop will not work correctly.

Reproducible: Always

Steps to Reproduce:
1.Open Composer
2.Type a four lines of text
3.Change the fourth line to the preformat paragraph style
4.Highlight the fourth line and drag it into the middle of the first one

Actual Results:
The line of text will be split. On the top line you will have what was to the
left of the dropped selection.  On the next line will be the dragged selection.
And on the third line will be what was on the right of the dropped selection.

Expected Results:
I would expect that the text would be placed on the first line and not create
seperate lines for the text I dropped it into.  Since it is in a different
paragraph format I would expect the dropped selection to take on the paragraph
style of the line it is being dropped into.

Comment 1

17 years ago
editorbase
Assignee: syd → cmanske
Whiteboard: EDITORBASE

Comment 2

17 years ago
Kathy: Is this rules code problem?
Assignee: cmanske → brade

Comment 3

17 years ago
Confirmed on Win 2k using build 2001110703.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Target Milestone: --- → mozilla0.9.9

Comment 4

16 years ago
In the build 2001121003 this is still an issue. An interesting result is, if you
do sort of an opposite and drag from the body text style to the preformat, the
expected result happens. 


Steps to reproduce

1. Open Netscape
2. Open new composer
3. Type 4 lines of text
4. Change 4th line to " preformat " 
5. Highlight 1st line of text
6. Drag highlighted text to the middle of " PREFORMATTED " text
7. Dragged text changes to " preformat " 


Odd thing that it does not work when going from " preformat " to " body text ". 

Comment 5

16 years ago
Regarding Comment 4, the same interesting note you mentioned is also occuring on
Mac OS X build 2001121805. 

Using the original steps as mentioned by the reporter, if you save the page and
open it in navigator, it will also show the split line. Apparently both
navigator and composer are also reading the "pre" tags as an insertion of a "br"
however it is not showing that in the HTML Source. 

Comment 6

16 years ago
Also happens with copy and paste. Type some normal text on a line, highlight
some text that is wrapped with an H1 or similar, copy and paste into the normal
text. You get a line split. 

Who owns copy paste?
Whiteboard: EDITORBASE → EDITORBASE+

Updated

16 years ago
Keywords: nsbeta1+

Comment 7

16 years ago
I think this is a duplicate of a bug on Joe's plate
(or hopefully he already knows about this issue?)
-->jfrancis
Assignee: brade → jfrancis
(Assignee)

Comment 8

16 years ago
this is by design.  Users have indicated they want h1,h2, ... copied even if you
select only part of it.  this is different from most other blocks at copy time.
 then when you paste, you are pasting an h1 into a pre.  DTD does not allow pre
to contain h1, so i split the pre.  working as designed.

discussion?
Status: NEW → ASSIGNED

Comment 9

16 years ago
OK, I'm with Joe (now that I understand the issue).
<pre> text will be on it's own lines (as would other paragraph formats).
Resolving as INVALID since this is desirable.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: Can not drag and drop text if it will contain mixed paragraph styles → drag text of different paragraph style doesn't inherit drop paragraph style

Comment 10

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.